Khadas VIM OpenWRT

Hello @ravelo

There is no SPI Flash for VIM1. The SPI Flash is on VIM2, VIM3 ans Edge.

@hyphop is working on this.:wink:

vim1 - added for testing - Linux Krescue-init 5.3.0-rc6
wifi - works

i will share soon


try to upgrade to rc8 before publishing

just today mainline: 5.3 released !


yeah, seen that in past hour !

any good news for vim1 ?

yes its almost ready! plz be patient) i have some special prio requests ))

1 Like

Привет! Могу-ли я установить OWRT под coreelec из терминала?

Можно более подробно что значит под ? из терминала ?

Сценарий такой: coreelec установлен на SD карту, он работает, подключаюсь к нему через локальную сеть по ssh, устанавливаю на карту OWRT пакеты

OK !openwrt for vim1 is ready


Very cool to see development on this topic, this device has good specs for using it as a router/wifiap.
I tested the latest img on vim2, looks good, wifi 5ghz work, but ethernet not.
I’m exited for a stable release for vim2 and testing the performance.
Samba on ubuntu server is a big inprovement in speed compared to a pi, looks promising.

Thanks for the work @hyphop


yes mainline kernel have some problems with ethernet for vim2
i will try to fix it !

vim2 openwrt status - WIP - plz wait !

1 Like


i will make release for VIM2 on next week !

i have check openwrt samba on VIM2, after some optimizes
i can get full gigabit bw transfer via lan (with 15% system load) its very cool

sure VIM2 only usb 2.0 and all transfer from real storage’s will be limited about 480Mbit

for VIM3 i can get full gigabit bw transfer from usb storages works fine - ready for highperfomance media storage’s

PS: VIM3 VIM3L openwrt release will come little bit later


Nice, i will test next week.

Cool to know this device is full gigabit and not a usb to ethernet bridge crap, make it esier with usb to ethernet adapter for wan without bottleneck the lan

1 Like

hi u can test openwrt for VIM2 its ready !!!

we will make announce and write more annotation tomorrow :wink:


hi openwrt fans ! some fixes again, plz re-download images
VIM1 VIM2 updated

Khadas Vims OpenWrt rel 0.3

  • added support for VIM2 ( with wifi chip AP6356S VIM2.V14 tested )
  • preinstalled samba, mdns, ttyd, thd + many other packages
  • fix ethernet for VIM2, but still not possible reinit ethernet interface for VIM2
  • improve startup speed - now is about 7 sec
  • LEDs indicators - supported
  • board buttons KEY_F KEY_P - custom usage KEY_F - reset wifi | KEY_P - power off
  • initial optimization for Ethernet USB MMC subsystems
  • many improves
  • change default hostname to openwrt-vim + mdns name to: openwrt-vim.local

Change log

Khadas Vims OpenWrt rel 0.2

  • usb 3g 4g modems - OK
  • improve build scripts
  • some changes

Now I have done some testing:

  • WiFi 5GHz works, but wifi channel not changeable
  • WiFi limited to 107 mbit/s over several distances, seems not to be a WiFi bottleneck (not 100% sure if the vim is the problem)
  • Change IP address range results in dead ethernet (build on own and change the settings before works)
  • No ethernet hotplug
  • SQM not working (one of the top reasons why i use OpenWrt)
  • Building from source results in opkg error (edit: already fixed, hadn’t seen)

Everything else working fine:

  • SMB speed = USB Speed
  • no issues in fps gaming on pc (eth) while use 1 4K streaming device (eth) and 5 smartphones (5ghz) (only little performance drop in WiFi, i will test later with 2 wifi antennas, now only 1 antenna is connected)
  • DHCP and DNS speeds good
  • Use a axix usb ethernet adapter as pppoe interface with vlan tagging works without problems
  • Stability is good no problems after 1 day usage

Thnaks for your Work!


tnx for feedback’s

Change IP address range results in dead ethernet (build on own and change the settings before works)

this is mainline kernel Ethernet driver problem only for VIM2 (this problem exist in every distros which use mainline kernel but nobody try to solve it :wink: poor quality of stmmac driver )
openwrt make ifdown & ifup for every netrork interface changes
… and after ifdown exec ethernet interface can not up again :wink:

simple solution just reboot device

another one possible solution is change openwrt iface scripts libs - its ugly way - but i can try to do it later

WIFI … channels

i will check it soon


i need to check kernel and may be enable or rebuild some modules
we use not native openwrt kernel - and we need to do something by hands (load modules or rebuild … etc )
i will try include SQM in next release

SMB speed = USB Speed

sure because VIM2 have USB 2.0 only, but u can test samba transfer by special test samba_test which work via RAM share
and can rich full gigabit channel

another situation for VIM3 openwrt with USB3.0 there samba not limitted by usb bandwidth, i will present it soon (still wifi problem not solved)

1 Like

i have spend half day and fix this problem - now VIM2 ethernet work fine without any bugs, plz check last version!!!

last version is V0.31