Khadas Tea is not putting out any audio

I have had a Khadas Tea since the beginning of March 2023. It worked well with my i-phone 14 for a time but has stopped putting out any audio. This is true both when using the provided USB C- to Lightning cable and with the bluetooth connection. I also tried using the provided USB C-USB C from my computer to the TEA but still no audio from the headphone jack. I have tried several sets of headphones including HiFiman Ananda’s, 7HZ Timeless (IEM), Sennheiser 660s and none work on the TEA but they all work with other amps. All of these headphones previously worked with the TEA. It stopped working about two weeks ago and I have tried troubleshooting in a variety of ways by using other cables, USB connectors and a variety of headphones. The unit is charged fully and shows.

What do I need to do. HAs there been a firmware update that I should be using?

What is the status of the light?

It is blinking green

You can try to connect your iphone by bluetooth,and check if it work well.Do remember to do not to connect any USB device.

Let me give you a few status reports…
When charging and using the Khadas provided USB C to USB C charger, the red light comes on until it is fully charged. Then the light goes off. So I know that the USB C port is working and that the light is functioning as it should for charging.

When using the USB C to Lightning to connect the TEA to my iPhone 14, the blue light flashes slowly and then rapidly. However, no sound will come out of the headphone jack. The music plays on the iPhone speaker instead. During that time the two buttons on the side of the TEA will not change volume or track. the only button that works then is the power on/off at that time. I have also tried a couple of other USB C to lightning cables to see if that is the problem. They all give the same result. It is not the cable. I have also tested the original cable on other devices and it works.

Then when I disconnect the USB cable and try to use bluetooth: I turn off the TEA and then restart it holding the power button for 6 seconds until I get the flashing blue light. Then I go to settings on my phone and connect to the TEA. When I do that, the TEA changes to a slow green flashing light and the music stops playing fro, my phone’s speaker but nothing is coming out of the TEA’s headphone jack. I have tried it with multiple headphones that have worked with the TEA before. I can see that the music is still playing on my phone’s screen (but no sound) and I can also see that the bluetooth is connected to the TEA on my phone. Still no sound and the volume/track buttons do not work. The green light is still slowly flashing on the TEA.

Unless there is a way to reset or a firmware update that will fix this, the TEA does not work. What can we do?

PS The unit has never been dropped, never been wet, and the case is in perfect condition. I have also looked to make sure that there is nothing in either the headphone jack or USB port. The unit just stopped working.

When you connect your Tea to your phone by bluetooth, can you hear a prompt tone from your headphone?

No, there is not a prompt tone when I connect my TEA to my phone via bluetooth.

I think that the unit is defective and needs repair or replacement. What remedies do you suggest? I have had it a very short time.

OK,you can ask our after-sales sevice for help,and sent it to us to have a check.
And do not forget to tell me the serial number on the box.

Thank you. How do I contact the After-sales service for help? I can’t find any such place on this forum.

ORDER PLACED with Amazon
February 21, 2023
ORDER # 113-8735316-8460205

Brian Wagner
ORDER # 113-8735316-8460205
Delivered Feb 27, 2023

I understand from Lily that you have my Khadas Tea on site now. Any idea when you’ll be able to diagnose the problem?

1 Like

I have received your tea,when I connect to our PC by USB C cable,and check the PID and VID by ESS burner,and find the PID and VID of the tea is wrong.The right PID and VID is 3353 and a005.The picture is shown below.

The reason is that the firmware is missing. If you encounter the same problem next time,you should update the firmware again.The method is following below.

  1. Download the firmware here.

  2. Download the ESS burner here.

  3. Follow the operation of this manual.

Can you take a picture about you tea box?Let me know your serial number,such as the following picture below.

Hi Eric,

That is strange. The unit worked for a couple months and then stopped working. What would cause the firmware to go bad? Also, I use an apple devise so I use a usb c to lightning cable. Is that what you are using/testing? Also, I did not send back my original box. Do you think you could be looking at someone else’s unit?

In any case, if it’s working, will you be shipping it back?

Thanks for your help.


I don’t have the original box any more. :slightly_frowning_face:


Yes,we will ship it back soon.It is caused by ES9281AC_Pro,EPROM is not protected.

OK,you should not take photo about the original box.

I received the Tea back in the mail today and it is working well again. Thank you so much for your help!