Khadas Remote (Power on/off)


How does the power button work? I can turn off the VIM3L with the power button (white led turns off). But there is no chance to turn the VIM3L with the power button on. I already tried to hold the power button longer but nothing works.

Do I miss something?


Hi Damian:
I guess you use the USB HID remote, right?

Only Khadas Official IR Remote support the full feature of Power on & off now.

Good day!

Hi Gouwa,

I am using your official IR Remote, due to I ordered the HTPC Kit with Khadas Remote.

How can I get it to work?


I have same exact issue. Received my HTPC Kit with Khadas Remote ans unable to power on with remote, however, can power off.

Hello @damianar1984 and @maxm811, What OS is on your VIM3Ls?
I do not have the VIM3L but I do have the VIM3. They share many similarities. I am able to boot up the VIM3 with the IR remote.

VIM3 and 3L include a feature called KBI. KBI can be used to set the VIM3L to either boot from IR or not boot from IR. I assume the VIM3L defaults to booting from IR, but I would be curious to see that KBI setting.
For now, a Serial debug tool(USB-to-Serial adapter) is needed to access KBI.
If one of you has a USB-to-Serial adapter, could you check this setting?
Relevant KBI function…

  1. Boot Trigger Events
    … supports different events for triggering boot-up:

    WOL: Wake on Lan
    RTC: RTC timer
    IR: IR remote controller
    DCIN: Plug in the DC adapter
    Key: Power Key/Button
    GPIO: External GPIO events

This means that when your VIM* is powered-off, any of the above events can trigger it to power-on; when that trigger event has been set to the “enabled” status.

@frank please confirm and response.

@Gouwa @maxm811 I check it now

@maxm811 Hello. I check it just now. You just need use a short press with power key . VIM3L_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190917 that which was I used.

same problem.
Coreelec is preinstalled.


I don’t get it.

You mean we have to use the power key on the right side of the VIM3L to activate the IR Function and then we can turn the HTPC with the remote ON?

I confirm. With official Khad remote control switches off but does not switch on.

1 Like

Same problem, the remote does not turn on vim3l htpc kit.
On the other hand, if I connect an external USB keyboard (Logitech K400 plus), the remote goes crazy, the buttons do not respond or execute whatever they want

I think our users are talking about CoreELEC on VIM3L, not the Ubuntu or Android :wink:

If the CoreELEC with the issue, we have to feedback to CE Team.

Yes, about VIM3L HTPC kit. + CoreELEC

@damianar1984 Sorry. I didn’t notice that CE firmware was used. I will communicate with CE team

I can’t understand how these Vim3l/Coreelec units went out the door without the capability of using the power on function of the provided khadas remote. I understand that this is probably a Coreelec issue pertaining to the Vim3l but releasing these units without the basic function of power on via the supplied Khadas remote is I believe incompetent. Sorry if that is to strong a term. I can accept some issues to come up with the Coreelec implementation with the new Vim3l as would-be expected with any new hardware introduced with Coreelec and I can live with that as the bugs are worked out. But come on now a non functioning power on button! :kissing_heart:

1 Like

@Dbwpg We are sorry for this. The CE team will complete the new firmware this week and fix this problem at that time .

1 Like

Great. Thanks for the update. Looking forward to the updated firmware.

@Dbwpg I will back here to tell you when the new firmware updated.

Do we know something new? Is there an update? What is the last one? How do you download it?
I still can’t turn on my vim3l with the remote

1 Like