Khadas Edge2 Windows image/OS USB ports not working (closed)

Which system do you use? Android, Ubuntu, OOWOW or others?

attempting to use the oowow WINDOWS provided image

Please describe your issue below:

The windows image provided in the OOWOW network install menu is not useable. The USB ports don’t work after the almost 2 hour install (EDIT: the usb 2.0 ports don’t work, the usb-c port opposite the PD port works), when it loads into the “setting up windows” screen for the first time, all users find that the usb ports no longer work making the computer unusable.

Post a console log of your issue below:

If this doesnt work then I guess there is nothing you can do:

sudo bash -c ‘echo host>/sys/kernel/debug/usb/fc000000.usb/mode’

Where would I enter this command? that appears to be a linux command, which wouldnt work on windows even if I had the ability to type it, which I dont cause theres no USB.

Have you heard of WSL?

I don’t think you understand the issue, i cant interact with the edge2 in any way shape or form, once the windows OS provided in the OOWOW menu is installed it becomes a $300 paper weight. if i had the ability to install wsl I wouldn’t have needed to ask the khadas team to fix it in the first place. but more importantly this isnt an issue with my specific use case or my implementation, this is a fundamental flaw with the product because it doesn’t work for anyone.

Yes it does. Just flash oowow back using rkdevtools.

Flash oowow extract the file from .img.xz to .img. Use rkdevtools flash oowow back and it will give u all the options.

Update: See if this helps (Solved) Flashing Uefi 'killed' my oowow restore - #5 by DarkevilPT

again, you dont seem to understand. i dont need to reflash OOWOW, its allready running OOWOW. OOWOW works fine, its the windows image provided in the network install tab of OOWOW that doesnt work, the only propper way to get windows on an edge2…

if i wanted to waste 10 hours now and 10000 hours in the future i could create a custom windows image and install it via removable media but this isnt for my own personal little hobby project. this is for a $30,000 industrial control system which we will be producing hundreds - thousands of.

You realize… that Windows on ARM is not oficially supported on rockchip cpus right? They are sided with qualcomm and… this ‘hack’ is just that. Whatever comes out of that can maybe be discussed on Windows on R project.

But… I see this is some what personal… I will stop interveining letting khadas have their chance.
This board… is better for linux… u should know that.

1 Like

im well aware that its intended to run linux and im well aware linux runs more efficiently and effectively on it, i personally preffer linux over windows. however they provide, in their OOWOW options, a windows operating system. we designed our product to use their boards because they offer a windows operating system, because our customers want a windows operating system. so all im asking for is their help in actually being able to use that windows operating system that they offer, which, presently, doesnt work for anyone anywhere.

1 Like

The USB host seems not work, but the USB Type-C port works, you can try a Type-C adaptor to connect your keyboard & mouse.

@Electr1 will help you later.


Thankyou for your help, i will start the re-download now. i recommend putting a notice in the download window similar to where it says “press shift+F10 to bypass network request” as from my searching through online forums there are many people who completely gave up using your product because they couldn’t get it to work.

1 Like

I had to make a custom adapter to get it to fit next to the HDMI socket but i was able to configure windows, thank you for the recommendation. Unfortunately the other two usb sockets are still unresponsive and also the wifi adapter is not recognised by the operating system. additionally the 1024x600 screen we need to use still just shows random lines and flashes and patches of colour. any help would be appreciated

Hi @shasta

Thank you for trying out the windows image for Edge2 and providing your feedback, here are some key points about the windows image I would like to share.

Regd. guides for using the image you can check it out here: Edge2 Windows install ARM UEFI [Khadas Docs]

The image is very much just experimental and was shared for enthusiasts who wanted to try alternative firmware on their Edge2, we don’t recommend using it in end applications as we can’t guarantee any stability of the OS.

we will update our document with more information shortly, but here are some notes that are yet to be added:

  • Windows ARM images only ship with USB 3.0 drivers, so the only operational ports should be the USB 3.0 A and C port

However, as you note peripherals connected won’t seem to work because they will only connect to the USB in the 2.0 mode, you need to use a USB 3.0 hub connected to either of the USB 3.0 ports to be able to have input devices, network cards or more.

You can check the progress of support here:

As evident a lot of things may not be working, but you should be able to get a barebones desktop, but we will keep tabs on the support improvement, but nothing can be confirmed in the current-near future.

Thank you!

1 Like

Hi Electr1,
Thankyou for the explanation, we greatly appreciate your time. given the limitations and difficulties with the windows image, we have discussed the matter with our customer and they are happy for us to use a windows skin on ubuntu. this should solve the issues with the usb ports and wifi adapter. this only leaves one problem to solve, the screen we are using shows random data. this issue was solved for another user some time ago, we are using the same screen as that user however the solution was never clearly stated in that topic discussion. I have created a separate discussion for this problem to help others find it in future: Edge2 doesnt work with 1024x600 HDMI screen


most welcome to provide the info, also please share details regarding the model and maker of your display in the other thread, this will help the devs to acquire a similar model to test and provide a solution quicker.


All relevant information (images, part numbers, links, edid) has been added to the new discussion. As this issue is now closed thanks to your help, I have edited the title and description to help future users as this thread is now the first result on google for [Edge2 windows USB]. Thankyou for your assistance.