Install third party OS problem

Which system do you use? Android, Ubuntu, OOWOW or others?

other

Which version of system do you use? Khadas official images, self built images, or others?

regular-gnome-latest-aarch64 (Regular - ALT Linux Wiki)

Please describe your issue below:

Good time everyone! The problem is that it is impossible to install images with an ISO extension via the USB flash tool. When starting the installation via USB and SD card with an EFI script, the installer does not see the emmc memory. What is the reason for this blocking? After playing around with images from owoow, it became necessary to install a third-party distribution and I realized that the USB flash tool was the only option. However, judging from my side, it seems that the development of this utility was abandoned, I could be wrong and I apologize for earlier.

This problem was raised in the post above, but all attempts to repeat it due to my inexperience led to failure. On the official owoow website it is written about full support for this utility; however, most scripts for installing ALT linux are not provided for Edge 2.
I would be very grateful for help with my experiment. Let’s say a current link or perhaps instructions on how to install on Edge 2, let’s say the official UBUNTU from github, and not a crooked resemblance to a rebuilt Frankenstein. Thank you very much and sorry if I was wrong somewhere.

Post a console log of your issue below:


Logs now there is no way to send edge 2 now without any system it lies and waits for ALT linux)

Hello @Georg_Povolyaev

@hyphop will help you then.

1 Like
  1. OOWOW [Khadas Docs] can help you with many problems
  2. another one Edge2 Online burn [Khadas Docs] - simple way to write image directly to emmc - for linux users only
  3. Edge2 Install OS into eMMC via OOWOW [Khadas Docs] - another way OOWOW API

Wellcome

1 Like

What .iso images are u trying to install?
From what I understood .iso images or .img images are for uefi which requires u to flash uefi to boot .isos from your usb… if you are trying that on the edge 2… brather my experience sucked… I cant stand to loose oowow over the current uefi.

If what you want is Arch Linux please try this guide:
Panda and Kwankiu are and have been working on arch linux for the arm boards and they actually have working images on the most recent kernel 6.1 and 6.8 (however mainline is broken better stick to 6.1 or 5.10).

kwankiu is soon to make upgrades on our side and will eventually get it working perfectly.
Try pandaa image for now.

To all images all u need to do is basically put them into your usb into yourel edge 2 booting into oowow and selecting ‘all’ to see all files in ur usb and flash them.

Or armbian:

1 Like

what a problem with UEFI - try to write uefi properly into emmc rby right way Edge2 Uboot UEFI [Khadas Docs]

PS: yes this UEFI firmware unofficial and sure may have some problems, but in my case works, and can start any OS, freebsd, windows, linux, but UEFI can’t solve all problem , for example if you distro can recognize emmc properly or has some other drivers problem

I did that process but ive ignored the ‘important’ code.
All I did was the next step ‘write-uefi-to-emmc’ code.

It worked I was able to boot uefi and boot openSuse.
However… Upon installation both opensuse freeBSD and Armbian couldnt detect my emmc storage… and that… was the ‘sucker’ part.

All images Ive tried couldnt detect any free storage obliging me to either use the same usb I was booting the images from as its storage or as I did connecting an nvme via usb c and using it as Storage … as U can imagine… it run dead slow.

Idk what I did wrong in the process to get uefi installed that emmc couldnt be detected as storage… @Electr1 was my saviour getting back into oowow and everything was fixed.

So yeah I had a bad experience but it wasnt khadas fault… probably just a bad procedure.

its already another problem :wink:

1 Like

But is that how its meant to be ? Or I just made the mistake of flashing uefi on emmc other than spi and one led to emmc not being the default storage ?

Either way makes it some what impossible to use for uefi images.

Worst than that is that… the feeling I had overall is that all uefi images are way heavier than properly images so its best to keep ourselfs to the armbians or arch linuxs light weight linuxes that can run better on our boards … otherwise it feels like windows 11 for arm…

Thank you very much for your answer, did I understand correctly that if the OS is distributed only through ISO, then it is not possible to make it into a format suitable for owoow? Is it easier to take the additional distribution and build the applications inside for yourself?