I want to use GPIO PINs instead of I2S PINs

Hello
I am going to use GPIO using vim3 and ubuntu 20.04.

I want to use PIN29, PIN30, PIN31, PIN32, PIN33 as GPIO like PIN37 of VIM3.

But I don’t use this pin as GPIO because it’s not GPIO.

So I’m writing to get some advice on this issue.

I referred to the above articles, but I couldn’t solve them.

The location of the kvim3_linux.dts file could not be found and an attempt was made to “Fenix Script Set to Build Ubuntu/Debian Images” failed due to an error.

Please help me.

@Sunny you need to build the fenix image in an x86 device, not in the VIM3 itself…

you can also use the github script to build fenix images as you require:

Thank you.

Thanks to you, I think I know how to solve the problem.

But one of the two questions remains.

Do you happen to know the location of the file kvim3_linux.dts?
Can’t I install ubuntu and find the file right away without any other process?

Do you think I have to go through that “Fenix Script Set to Build Ubuntu/Debian Images” process to check it out?

This command doesn’t work for me.

$ diff --git a/arch/arm64/boot/dts/amlogic/kvim3_linux.dts b/arch/arm64/boot/dts/amlogic/kvim3_linux.dts

Thank you very much for your reply.

@Sunny if you need the dts file, you need to check the khadas linux kernel repo

cheers!

2 Likes

Thank you.
I’m trying to solve it with your help.:grinning:

I tried by referring to the post, but failed.
Am I not allowed to modify the “config-template.conf” file?

I am using VIM3 and ubuntu20.04.

KHADAS_BOARD=VIM3
LINUX=2015.01
UBOOT=4.9
DISTRIBUTION=Ubuntu
DISTRIB_RELEASE=focal
DISTRIB_TYPE=server
DISTRIB_ARCH=arm64

Is it wrong to do this?

I tried to compile but failed.


I installed this ubuntu version
“VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530.img”

@Sunny first of all, please don’t give a pull request to the khadas fenix repo, it isn’t relevant there, delete it as soon as possible

and also please disable the unecessary workflows, they will be triggered aoutomatically and will inhibit the main workflow from running

I’m sorry.
I didn’t know because it was my first time.
How do you build a fenix in vim3?

@Sunny its very simple,
I’m sure you know how to setup the building script,
the thing is to check the *.conf file to make sure you don’t have any incompatible settings
(eg. mainline linux and 2015.01 uboot) etc.

your error in the .conf file is that linux is supposed to be 4.9 not 2015.01
so change it to

LINUX = 4.9
UBOOT = 2015.01

it should fix the issue :slightly_smiling_face:

also remember to disable all other workflows other than build firmware,
if you have a redundant build, you can right click on the side and cancel the workflow
cheers!

1 Like

Thank you.
I’ll try again.

Thank you for your kindness. :grinning:

1 Like

Thank you!
Thanks to your kind reply, I solved it. :smiley:

1 Like

OH, Can I ask you one more question?
There was an error while making it, do you know what is the problem?

um, I am not sure about that error,

but also don’t use WSL for building Fenix Ubuntu/Debian images, you with get port errors while building rootfs of the image,

WSL uses a different port number for getting ubuntu packages, and hence it will not work
I suggest using Virtual box with ubuntu installed in it for building fenix…

1 Like

I didn’t know because it was my first time, so I asked a lot of questions, but thank you for your kind response.

no problems, if you have more doubts you can also ask in the discord (non-official) chats :wink:

This post was flagged by the community and is temporarily hidden.