I cannot find pinctrl for gpio mux selecting in kvim3_linux.dts

I want to change mux mode of gpio for

I need multiple GPIOs. So we want to modify dts to modify the mux mode of the gpio pin.
But I don’t know what part to fix in kvim3_linux.dts.
Can you tell me which part I need to modify for gpio mux selectging?

Which PINs you want to use?

I need PIN29, PIN30, PIN31, PIN32,PIN32, PIN33 of VIM3

But it not GPIO,

I cant write 1 to these GPIO with /sys/class/gpio/gpioxxx .

so i want to change mux seleting fot these gpios.

Thanks

Regards

These PINs are default configured as I2S, if you want to use them as normal GPIOs, you can edit the dts to disable I2S in auge_sound node.

I deleted the auge_sound node with kvim3_linux.dtb and dtb.img and tried status =“disabled” in the auge_sound node.

I also modified kvim3_linux.dtb and also dtb.img. However, either way I can’t set it to gpio. its is not working as gpio.

Could you please tell me how to do it in more detail?

I have another question.
at VIM3 , there are two dtb file , one is dtb.img , another is kvim3_linux.dtb

Which file should I use?

Hello @Frank

Please help to check this issue.

@debian

index 5183c62b27df..f6401be41679 100644
--- a/arch/arm64/boot/dts/amlogic/kvim3_linux.dts
+++ b/arch/arm64/boot/dts/amlogic/kvim3_linux.dts
@@ -571,6 +571,7 @@
        auge_sound {
                compatible = "amlogic, g12a-sound-card";
                aml-audio-card,name = "AML-AUGESOUND";
+        status = "disabled";
 
                //aml-audio-card,aux-devs = <&amlogic_codec>;
                /*for audio effect ,eqdrc */
@@ -978,6 +979,7 @@
                 * 4: spdifout_b;
                 */
                samesource_sel = <3>;
+        status = "disabled";
        };
 
        aml_tdmc: tdmc {

1 Like

Okay. It work well.

Thanks you