Hdmi no signal Vim3 pro

I’m sorry I accidentally closed my preview topic. I didn’t solve anything

@Minkows1 Did it work before, did this happen suddenly?

The Vim3 pro is new (including the spotless external film) but without warranty. It never worked

Someone could give me a valid email of Khadas. I wrote to hello@khadas.com, about my hdmi problems, but answer came there none. Thanks and regards

I wrote an email to hello@khadas.com, about hdmi problems and return, but answer came there none. Could somebody of Khadas company contact me please?Thanks and regards

@Minkows1 Can you try burning an Android firmware to see if it shows up?

I tried to install:

  1. android on EMMC
  2. ubuntu on EMMC
  3. krescue on sd card
    Always hdmi no signal on my tv and projector

I thought that Khadas was a serious company but I was wrong. I purchased a new vim that doesn’t work and nobody tell me if I can or not to dispatch it back to them or there is someone could check and repair it in Europe to avoid a risky shipment to China. I’m very disappointed and I don’t understand every flattery to this company

@Minkows1 I’m sorry about that. It was my work blunder, I ignored the replies to this thread. :disappointed_relieved:

What resolution is your TV, have you tried some common resolutions such as 1080p monitors?

at home I have only one tv (LG) and a new xiaomi projector 2 pro. I don’t have a monitor. I tried to connect the khadas vim3 pro to hdmi port on the tv and to an hub usb- hdmi connected to tv. I tried also to connect the vim3 pro to both hdmi ports of the projector but I always get hdmi no signal. Odroid n2+ and raspberry pi 3 work perfectly on tv and projector

hdmi cable and the power adapter are original khadas

Up this point its just a guessing game as to what is going on.

Do you have a Ubuntu box?
If so using pins 18 &19 Linux_TX and RX along with a CP2102 ttl to usb adapter along with some female ended dupont wires will be needed to debug what is going on.

Setup minicom as shown in the VIM3 manual.

Make sure the vim and adapter are connected to the Ubuntu box BEFORE you power on the VIM.

I never used Ubuntu and Linux in my life but I can install it in my Odroid N2 or can I use my Imac with high sierra?

Is this one ok? Is the Dupont cable already present in the picture?:

My knowledges are zero and I don’t know how many possibilities I will have

This is a picture of the adapter we use here. The seller in the link is extremely overpriced, they just have a good picture. We pay around $1.80 for these so that seller in the link is just chosen for the photograph.

If using this on a Windows box you MUST install the current driver or it will not work.

Also the dip switch must be set to 1 is on and 2 is off, slide switch toward the outer edge of the board.

I purchased it. It will arrive within 25 days. I will contact you when I will be ready. Thanks

1 Like

FYI, have minicom configured and running first, it works best if the adapter is connected to host and SBC before powering on the SBC.

Only one thing. I need a picture where I can check the connections from CP2102 adapter to Vim3 pins using the female cables. I think I will use a windows laptop. Thanks and regards

Here is a link to the silicon labs official download for the Windows driver

Uploading: Screenshot (14).png…

Uploading: 16524297107951262546346.jpg…