Hardware volume


#83

Hi Koozoop,

I also got a pb with dsd rendering with my raspberry 3b+ and Tone board.
I made the xmos firmware upgrade to get the hardware volume gestion, it works perfectly for all stream except dsd (like you), where i got loud and harsh white noise at 100% of the volume as soon as i hit play…

Fabien


#84

I’m on latest firmware. Is there anything else to do? I’m quite disappointed at the moment…


#85

I did not the upgrade and can play dsd64 with no problems so far. If you did the upgrade the issue could be related to the fact that DSD by definition requires 100% volume (max) so look for the setup in your system and make sure DSD volume is setup at 100%.


ddl Source code
#86

I’ll make a try with volume set to 100%.
I have to find a preamp, i got active speakers i use with software volume usually…

Fabien


#87

UPDATE: I tried the TB (tone board) with my Windows 10 PC and I got perfect playback from flacs to native DSD256 through foobar 2000. So the board is ok.
Then I tried a new Volumio setup on my Odroid C1+ and TB through USB. Perfect playback of flacs and DSD256 both with “none” mixer" and “hardware” mixer. DSDs playback wonderfully and volume is perfectly controlled from Volumio interface when in hardware mode! I had to resample setting only the sample rate to 384kHz otherwise I get “clicks”. “pops” and stuttering on DSD above 64.
Then I plugged it back to my main x86 Volumio player: same problems, ie no volume and white noise on DSD. So I tried a new Volumio installation though a USB key and voila, everything worked well!


#88

Hello,

You mean that would be just an Os installation bug ?

Fabien


#89

Exactly! An upgrade bug basically because I had the previous version of x86 Volumio installed an then upgraded to 2.555. So something went wrong during the update. Or maybe because I had three different DACs under test on this machine the conf file got “confused”. Anyway, it’s working perfectly now and I’m preparing my diy Volumio player based on an Intel NUC and the Khadas TB installed inside.


#90

Ok, that’s interesting.
Thanks ! :wink: