Gparted Crashes vim4-ubuntu-22.04-gnome-linux-5.4-fenix-1.0.11-220620-emmc-develop.raw.img.xz 827 MB 20-Jun-2022 12:41:37


Attempting to run gparted on vim4-ubuntu-22.04-gnome-linux-5.4-fenix-1.0.11-220620-emmc-develop.raw.img.xz 827 MB 20-Jun-2022 12:41:37 that results in an immediate reboot.

I am attempting to initialize an NVMe SSD attached to the New M2X Extension board with the following command:

mke2fs -t ext4 -c -c -m 1 -L SSDp1 -U time -v /dev/nvme0n1p1

That also results in a reboot after testing with pattern oxaa.

Is there an Ubuntu release that will permit the use of my NVMe SSD?


1 Like

Do you have any logs?

What’s the model of SSD you used?

Just checked the same image you are using with an 970 EVO and it works fine. Only thing I just noticed is firefox is flaky and will not allow a screen shot to be uploaded on this forum.

My NVMe was already formatted and was just removed from a server that is being tested. So I really don’t want to mess around trying to do a format on that drive in the VIM4. It does work when installed in a preformatted state, do you have a NVMe to USB adapter? That is how I do it and use gparted on a desktop to set up the partitions.

Just had to use a different machine to get the screen shot up so its not the forum.

Thank you for starting this thread! I’m struggling to format any of the drives on the vim4 using gparted, i.e. the onboard storage or the 1tb nvme ssd. I went down a rabbit hole in this thread: 970evo 1tb on VIM4 (new m2x)

Were you able to format your drive using gparted?

Thank you for your response.

journalctl only shows the log entries for the current boot, not the last session that crashed. If you’d like any other specific log files, please provide the command(s) to display them.

SAMSUNG 980 SSD 1TB M.2 NVMe Interface Internal Solid State Drive
The SSD is attached through the New M2X Extension board, and is heatsinked.

The VIM4 was powered through USB-2 from a ZMI PowerPack 20000. I believe this was the cause of the spontaneous re-boots. So, the VIM4 is now powered with a 60 Watt USB-C charger, and no longer re-boots.

However, powering the VIM4 with a more suitable power source did not cure the errors occurring while attempting to make a file system on the four partitions. Both mke2fs and mkfs produce errors in the final step of file system creation as seen in the output of the mke2fs -t ext4 -c -c -m 1 -L SSDp1 -U time -v /dev/nvme0n4p1 command below:

mke2fs 1.46.5 (30-Dec-2021)
fs_types for mke2fs.conf resolution: ‘ext4’
Discarding device blocks: 0/61084928 done
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=4 blocks, Stripe width=32 blocks
15278080 inodes, 61084928 blocks
3054246 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=2210398208
1865 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Filesystem UUID: 81b38e18-228e-41e9-8168-2268bae0fa64
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: 0/1865 done
Writing inode tables: 0/1865 done
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: 0/1865mkfs.ext2: Input/output error while writing out and closing file system

So, while powering the VIM4 properly has overcome the spontaneous re-boots, it has not permitted me to successfully initialize the NVMe SSD.

To determine if there was a fault in the NVMe SSD, I successfully created file systems on all four partitions on my Lenovo system under Debian Bullseye. So it would appear the mkfs failures are unique to the VIM4 with New M2X Extension board.

I appreciate your assistance with this issue.

Best regards,

Thank you for your kind assistance.

As you can see from my response in the message above, using another machine to initialize the NVMe SSD was successful. However, that shouldn’t be necessary; it should be able to be done on the VIM4.
I can wait for the issue to be debugged.

I’m wondering what sort of issues I may encounter when connecting the LCD screen. :grinning:

I am also experiencing what appear to be display resets about once every minute. I’ll start another thread to address that.

I can see that the Khadas team is very talented and conscientious, so I am happy to assist in debugging.

Best regards,

1 Like

Yes. But, not on the VIM4 yet.

Hang in there. They’ll get it worked out.

Best regards,

I did that, and I am now happy to be able to fsck and mount the SSD successfully. So, this workaround enable’s me to continue exploring VIM4 performance, but I wouldn’t call the issue solved.

Here’s the output from gsmartcontrol:

smartctl 7.2 2020-12-30 r5155 [aarch64-linux-5.4.125] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke,

Model Number: Samsung SSD 980 1TB
Serial Number: S64ANJ0R604862H
Firmware Version: 1B4QFXO7
PCI Vendor/Subsystem ID: 0x144d
IEEE OUI Identifier: 0x002538
Total NVM Capacity: 1,000,204,886,016 [1.00 TB]
Unallocated NVM Capacity: 0
Controller ID: 5
NVMe Version: 1.4
Number of Namespaces: 1
Namespace 1 Size/Capacity: 1,000,204,886,016 [1.00 TB]
Namespace 1 Utilization: 499,956,228,096 [499 GB]
Namespace 1 Formatted LBA Size: 512
Namespace 1 IEEE EUI-64: 002538 d61141174d
Local Time is: Fri Jun 24 21:06:30 2022 PDT
Firmware Updates (0x16): 3 Slots, no Reset required
Optional Admin Commands (0x0017): Security Format Frmw_DL Self_Test
Optional NVM Commands (0x0055): Comp DS_Mngmt Sav/Sel_Feat Timestmp
Log Page Attributes (0x0f): S/H_per_NS Cmd_Eff_Lg Ext_Get_Lg Telmtry_Lg
Maximum Data Transfer Size: 512 Pages
Warning Comp. Temp. Threshold: 82 Celsius
Critical Comp. Temp. Threshold: 85 Celsius
Namespace 1 Features (0x10): NP_Fields

Supported Power States
St Op Max Active Idle RL RT WL WT Ent_Lat Ex_Lat
0 + 5.24W - - 0 0 0 0 0 0
1 + 4.49W - - 1 1 1 1 0 0
2 + 2.19W - - 2 2 2 2 0 500
3 - 0.0500W - - 3 3 3 3 210 1200
4 - 0.0050W - - 4 4 4 4 1000 9000

Supported LBA Sizes (NSID 0x1)
Id Fmt Data Metadt Rel_Perf
0 + 512 0 0

SMART overall-health self-assessment test result: PASSED

And, here’s a screen capture of the Disks benchmark:

It looks a bit slower than your, but not significantly. Is your NVMe SSD operating through the New M2X Extension board?

Best regards,

Yes, it is on the new board.

Its pretty close to the VIM3 speed.

"Were you able to format your drive using gparted?"

Has this been fixed with one of the latest releases?

I haven’t touched my VIM this month, but have grand hopes of actually using the thing this weekend to automate my Plex request stack.