Forum Activities for Linux Mainline Support?

#1

Hello Everyone,

I have recent joined Khadas community as I plan to purchase a Khadas VIM 1 as it is good specs and have important interfaces for development phase.

I would like to know how active is the Community with regards to the mainline Linux Support, as I plan to work on Manjaro Arm Linux and try to port it to VIM1.

My decision to work on VIM will depend on the community support. So hope to hear more from the community members.

Thanks

0 Likes

#2

Good afternoon, the Linux version for Arch exists. Manjaro was not yet assemblies. But your assembly is possible, while I tried it myself, there are errors somewhere


thank you balbes150! :slight_smile:

0 Likes

#3

Yes, I am aware of the ArchLinux for Aarch64 as I am in the Manjaro Arm Forum already.
There is an image for orouid C2 which is exactly the same like Vim1.

Thanks for your instant reply.

Edit: BTW Is there any thread for Arch Linux for VIM1 ? Mostly I can only see for Vim2 and Pro.

0 Likes

#4

Unfortunately, I did not find anything for Vim1

0 Likes

#5

No, these models use different chips and approaches to the system. The main kernel supports VIM1 (not all items yet, but the main one works).

https://forum.khadas.com/t/archlinux-kodi-sd-usb-emmc/1152/24

0 Likes

#6

Did you try to flash od c2 rom on vim1?

I have ordered vim1 to test my skill so i might need your help in understanding the system approach of vim 1.
Maybe can get manjaro work on it with the help of manjaro arm team.
Thanks

0 Likes

#7

This cannot be done. You get brick. u-boot from Odroid C2 is specifically locked to run on other models.

I have already done the Assembly of Manjaro for VIM and run in VIM. Details can be found on the Manjaro forum.

2 Likes

#8

Thanks for the update.
I will follow your manjaro build post and go through it.

Just to know. Do we have a mainline kernel for vim1? With all the hardware components working?
As i can see most threads on here are unanswered.
So that i can look into uboot first.

0 Likes

#9
  1. Yes, VIM1 and VIM2 are supported in the main kernel (they have their own DTS).
  2. With the addition of several patches, all components of VIM1 work.
  3. you don’t need u-boot. It already exists on eMMC and works correctly. To run any external system, just add the desired script to the external media. See the examples of how to launch ArchLinux, Armbian and LE.
0 Likes

#10

That’s great.
Happy that we have vim1 dts.
I am aware of how to launch the archlinux but still i will go through it again to get in detail understanding of vim1.

And even if it bricked i hope i can access it with uart and unbrick it.

0 Likes

#11

maybe this can help you:

0 Likes

#12

Hello
Thanks for your reply.

I have been going through all the threads on this forum but mostly i can she is unstable roms.

And i couldn’t find any rom which clearly says stable and most of the io works.

I can start testing the latest ones once u receive me test board.

Thanks for ur support

0 Likes

#13

Hello dear,
I couldnt find your Manjaro for VIM THread in Manjaro forum.
Can you please share the link? EDIT: Found it
I will be trying to build it for KVIM1 using the manjaro-arm-tool developed by strit.
I will need your support with this development.

0 Likes

#14

If you have any questions, I’ll try to help.

0 Likes

#15

Thank you for your reply.
I read your post on manjaro forum.

I will try to learn and keep the KVIM1 Manjaro support on manjaro-arm-tools.
Now as you mentioned in your post there that we dont need uboot in the image. so I can use your PKGBUILD? Can you guide me what I have to do? Just the basics please.

0 Likes

#16

u-boot is not required to build the image. There are regular eMMC in u-boot and its better to leave and use the run mode with the external media through universal multiboot (it was made in all the images Armbian and Libreelec). When building an image, you need to create two sections (similar to Armbian or Libreelec and take ready-made scripts for launching and activating multi-boot). The first section is FAT. It will contain the kernel and startup scripts. The second section is EXT4. This is the root partition. You can take the partitioning scheme from the Manjaro build rule for RPI (two sections are used there too). The kernel can be built directly from the main git Linux 5.0. It now has almost everything you need to work on VIM1 \ VIM2 and EDGE. If you need full support for all elements (BT WiFi sound) for VIM\VIM2 - you can use my GIT with the kernel sources (there are additional fixes for these elements).

1 Like

#17

Great.

I will try it with your git first. I see that you have 3.14 with all things working.

I will try to build one tomorrow

0 Likes

#18

I do not recommend using 3.14. You’d better use the master branch in my GIT, it has the latest kernel 5.0.2 and it runs all the hardware on VIM1.

0 Likes

#19

Great.

Is there any other way to build mnajaro from buildroot or yocto like tools?
I mean other than the manjaro-arm-tool?

0 Likes

#20

Hello,

I modified the source url in your PKGBUILD file and tried to buildpkg using manjaro-arm-tool

and it failed with

int ____ilog2_NaN(void);
^~~
GEN include/generated/asm-offsets.h
CALL scripts/checksyscalls.sh
:1232:2: warning: #warning syscall renameat2 not implemented [-Wcpp]
KBUILD_CFLAGS_MODULE:-DMODULE
CHK include/generated/uapi/linux/version.h

The present kernel configuration has modules disabled.
Type ‘make config’ and enable loadable module support.
Then build a kernel with module support enabled.

make: *** [Makefile:1072: modules] Error 1
==> ERROR: A failure occurred in build().
Aborting…
==> !!! Package failed to build !!!
-> Cleaning build files from rootfs

I just made all the config as default using enter key all the way :slight_smile:
I see that this module support was not enabled in the kernel. Does Kernel 5.0.2 have this support?

I am trying to build it with 5.0.2, i will get back to you with the result.

0 Likes