Firmware VIM3_Pie_V200103+M2X+ME906E

After updating Firmware VIM3_Pie_V200103, I stopped seeing the HUAWEI ME906E 4g module, everything worked in Firmware from VIM3_Pie_V191122, can you fix the firmware. Thanks.

@vviippaa I think its because the 4G modules supported only in new firmware. I hope that is the correct reason,:slightly_smiling_face:
update to the latest firmware and see if it works now

The VIM3 came today. I immediately installed the latest android firmware. Unfortunately, he does not recognize my Huawei ME906s LTE modem. How do I have to make the LTE modem run on Android?

it is necessary in this case to switch your device in the settings from usb 3.0 to psi-e

I’ve already tried that. Unfortunately, this is unsuccessful!

after that you need to reboot the device, and check again.

You can try flashing Ubuntu rom and get tested

That is of no use to me. I only bought it because it runs on Android. Unfortunately Ubuntu is of no use to me.

I suggested you check and return to Android

@ThomasHH-DE if are going to use a different modem other than the quectel one , you will need to have modded firmware, to include support for it especially in v200624 of android

need to ask Terry if this modem has support, but I think that it is supported in the main firmware, since it is supported in Edge, it’s clear from the description

You also need to update your android to the latest version!

Even in the latest firmware VIM3_Pie_V200624 I am not shown an LTE modem

@ThomasHH-DE, please refer to my above post,

I believe support was dropped for the Huawei modem

OK, then this is the wrong product for me. I will send everything back. This is not a problem with the Leez.

@ThomasHH-DE, If you ask @Terry he might help you get the modded firmware, you are a valuable part, of our community, everyone is, it hurts for me to let you down, is there any other way the community can help ? :slightly_smiling_face:

1 Like

probably you had little time to figure it out, you need to go through the forum to understand a lot

I don’t think this is a product that can really prevail here in Germany. The VIM3 really only seems to run on individual hardware distributed by Khadas. The Huawei ME906s LTE modem is a common model which is also installed in many Lenovos and works well on the Leez. I don’t want to bake my own Android. There are ready-made images for that. There also doesn’t seem to be a place where you can get Custom Roms. If I want to run Ubuntu, Libreelec or Debian on an SBC, I can also use a Raspberry. The community is very large here. I connected the touchscreen to the VIM3 again. Since I read here in the forum that it is probably not so easy to get a 7 "touch display via USB to run. Sorry, - these are basics!


here’s the proof that Khadas supports your modem!

On Ubuntu. I need the support for Android.

if supported, then everywhere