Fastboot doesn't detect the device

Which Khadas SBC do you use?


Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

It doesn’t matter.

Please describe your issue below:

On Ubuntu 22.04.4 (fastboot version 35.0.0-11411520) and Windows 11 (fastboot version 3db08f2c6889-android from the “fastboot_update” archive), I tried to reboot fastboot in the VIM3 device, and the next command like “fastboot flashing unlock” I got a “< waiting for any device >” message.
On Windows in the Device Manager after the “adb reboot bootloader” command a new device appears with the “USB download gadget” name and without an installed driver.
It seems to me, there is a problem with the driver for fastboot on Ubuntu and Windows. How can I install it?

Hello, the following post should be the same as the problems you encountered, it should help you solve

Fail to boot to fastboot mode on VIM3


I saw this post. Unfortunately, it doesn’t help me.
But I found the solution for Ubuntu: Khadas VIM3 / VIM3L
But there is still the problem for Windows. I tried commands of the solution from the post, but I got the same issue.

Is fastboot.exe in adb platform-tools placed in the adb directory?

I tried it, and, unfortunately, I’ve got the same result :frowning: