Fails to Power On

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas official images

Please describe your issue below:

Device will not power on. After about 1s of plugging USB-C power in, the right LED glows red. Pressing FNC and PWR, the red LED goes out for about 1s, and then re-appears

Post a console log of your issue below:

Not possible

Hello @Andrew_Ernest.

To boot into OOWOW you need to press Reset + Function, then release Reset and hold Function for a brief moment.

Try it out.


Thank you for responding. Unfortunately nothing happens - the red LED stays lit amd there is still no signal through HDMI. The left LED does not light at all

@Electr1: I understand it is a holiday in China. Please let me know what to do next as soon as you return.

Hello @Andrew_Ernest, what happens if you triple click the Function button on the side ?

Try this guide to restore OOWOW onto the SPI flash.

  1. Restore OOWOW firmware
  2. OOWOW Guide


@Electr1: Thank you for responding. Triple clicking the Function button results in the red led cycling through 3 sets of quick double flashes, then goes out, and comes back on a few seconds later. Following the instructions on restoring the OOWOW firmware stops at

"wait device with upgrade mode - need press KEY_FN 3x times - "

with the burn software not recognizing the USB connected Edge2.

Plugging the Edge2 into the Ubuntu 22.04 PC USB 3 port, connected to either the PD or Data+PD USB-C port on the Edge2, lsusb does not show any device added.

Are you able to see something like this ?


Maybe the device is not receiving enough power, you could try plugging the USB-C- PD port to PSU and other USB-C 3.0 to the computer, this way you can run with enough power to boot.

Let me see if I can take a video of it. But, yes, I have tried a PSU on the PD port and the other to the PC, with no change

@Electr1: the forum will not let me attach videos. Unlike your device, the left LED does not come on at all, and the right LED only ever shows red.

Hi @Andrew_Ernest ,I think we need to see what solution we can provide. I request you to wait till our vacation period is over to communicate about this issue.


Of course. I did not realize you were still on holiday.

Hello @Andrew_Ernest

Can you take a viodeo about your operation ?

I have video, but the forum web app will not allow me to upload a video

you can share the video via online fileshare or youtube also.

Connect a screen on hdmi port of edge2.

Hello @Andrew_Ernest

When you plugin the adaptor does the Red LED is solid on ?

It takes a second or two, but yes, when I plug the adapter in, the Red LED is solid on.

Please press the POWER key to start.

Please note that this is why I am here in the first place. Pardon the video, I had to manipulate the device with one hand while holding my phone in the other.

Plugging the power in, the RED LED lights after a few seconds. Pressing the power button, the RED LED goes out and then comes back on.