Edge V - Linux installation not working

Hi I am desperately trying to install linux on my khadas edge V.

I tried on both Linux and Windows host. USB and SD installations.

Nothing has worked so far.

On windows when I use the RKDevTool/android tool, I get the “no devices found” (tried booting on normal and upgrade mode). When I using the SD disk tool, and using a fenix image and Edge_Ubuntu-lxde-bionic_Linux-4.4_arm64_SD-USB_V20190830 I get the message: “Opening firmaware faileds”.

On linux when I try to install via USB, I get something like not in upgrade mode. But as far as I know it is and the image out of HDMI shows I am on upgrade mode.

Any idea why is this happening?

Upgrade with USB cable, please check here:

For SD image, you just need to dd the image to SD card and insert it to the SD slot and reset the board then it will boot from it.

Hi thanks for the prompt reply!

USB cable on Linux has not worked for me.

I have managed to install via SD but only the desktop version ( Edge_Ubuntu-lxde-bionic_Linux-4.4_arm64_SD-USB_V20190830)

Fenix image for mainline Ubuntu server has not worked, also when trying to get fenix cript to make mainline Debian server it throws an error (some jpg lib if I remember correctly).

Going to try more Fenix versions

Maybe you need to provide the error logs…

Finally made the fenix script work!

But after many configurations I have not been able to make a image with mainline uboot boot.