DVB/DTV Extension Board for VIM2 (VTV)


dear Robert

sorry but we don’t have plan to make VTV board to support ATSC

besides, we make OTT(Android)+all kinds of DTV STBS, please contact me if some one interest on that.


Today I tested first working build.
Work progress:

  1. serial2parallel conversion in S912 is working;
  2. driver is now able scan channels, I tested it for dvb-s and dvb-t;
  3. blue channel lock led is fixed;
  4. live tv playback is working only for few channels, I have to fixed this issue.


Fantastic progress. Do you have a Beer account ?



Testing version, partially working driver for VTV board.
This image is for upgrading already installed LE. For testing download SD card image
https://libreelec.adamg.co.uk/releases/LibreELEC-S912.arm-8.90.5.img.gz and upgrade it with testing version.
Testing dvb driver is only installed in “DVB drivers for TBS (CrazyCat)”. You have to select them in Add-ons->LibreELEC Module Drivers.
Testing version is able scan dvb channels in TVheadend42. Some channels is able play, some are freezing after few frames.
This version is fully functional LE 8.90.5 version. For RC issue look in LE forum or use USB keyboard.


Not happening for me at all. Finding nothing on either the DVB-T or DVB-S scans.
Got this dmesg:

135.517157@6] i2c i2c-2: Load avl6862 firmware patch for DVB-T/T2 size=65048
[ 137.385627@7] i2c i2c-2: avl6862 patch ver 2.0 build 20544
[ 137.485664@7] i2c i2c-2: avl6862: failed to enter DVBTx mode
[ 151.718326@4] i2c i2c-2: Load avl6862 firmware patch for DVB-S/S2 size=44000
[ 152.045595@4] i2c i2c-2: avl6862 patch ver 2.0 build 20621

Tried it first on my TVHeadend 43 which was previously installed and then switched to TVheadend 42.

update: Going to try a fresh install from USB.

Update: I had to delete the already installed CrazyCat module and then reinstall it again before it would start scanning. Its now scanning and has found 83 services so far.

Update: Yep, working. Most channels work after a fashion though it seems not with HD accelleration.

Update: Since attempting to plug in my HDStar tuner I have lost the LNB connection on the dTV board and so cannot get it to tune to the sat. it still tunes the DVB-T however. Hope I haven’t damaged my board somehow.

Update: Got LNB back on the dTV board by disabling CrazyCat drivers and then re-enabling it. So there maybe issue with clashes between the dTV card and some USB tuners.

Update: I think the problem I am encountering is the switch between DVB-S and DVB-T. I am currently running two streams of DVB-S, one from the dTV card and one from the HDStar USB. However once set on DVB-S it will not allow the dTV card to switch onto the DVB-T channels without re-setting the Crazycat addon. This is something you can do seamlessly within the Android DTV app. So it seems the card gets stuck as either a DVB-S or DVB-T.



New findings. Current hw demuxer setting is in collision with hw decoding. You can verify this by disabling hw decoding -> all channels are working. Also you use kvim2 as a tvheadend server and watch channels on PC or another tv box.


When I switched the VIM2 back on this evening it was not finding the LNB attached to the DVB-S input which it was using when I switched off last night.
The board has now got completely stuck on DVB-T (which is working) and I cannot get it to find the LNB on the DVB-S input. The HDStar USB tuner is working off one of the 4 outputs of the 4 port LNB so the LNB is working.
If I can provide a log tell me what you need.




Please upgrade your software to latest Android Version, and take a logcat from startup to enter VTV software. tks


This is the testing build of LE not Android.



Yes. All channels are working, but very slowly and with freezing


The channel lists I was getting using this version of the drivers and TVheadend were very small and missed most of the essential channels I wanted. I imported the channel list from my previous Tvheadend setup and it seems to work fine. I have found that if you stop the channel before switching it doesn’t crash - otherwise it tend to lock up badly. Haven’t tried DVB-T again but will do so.

It is still having issues with:
-getting stuck in DVB-T mode
-will not work reliably in conjunction with another DVB-S card
-seems to randomly mess up its configuration
-doesn’t seem to have as good reception as my old DVB-S card in my PC on the same LNB



Some of the Addons must have been updated lastnight. My carry over TVH 4.2 config broke and I had to delete it and reinstall the build and rescan to get things working again. Its probably an update to the driver module and/or the TVheadend server.
Since that things have improved:

  • the onboard dTV is working better with the external USB DVB-S tuner.
  • the hardware decoding is now working after a fashion and the freezes seem to have gone. However when streaming from the onboard card and using the VIM2 to view the playback is very “jolty”. If streaming to an external TV from the dTV board things are fine, and the external DVB-S tuner players without stutter simultaniously.

This is a big step forward, though things tend to be a bit random in the overall behaviour with tuners locking up unexpectedly. Channel switching frequently results in no adapter been available.



Yesterday I updated the drivers module and the TVheadend server. I also set “Force Old Status” on the dvb settings tab.
Since then the drop outs of the tuners has disappeared (they stayed alive overnight) and running both the internal and external tuners works fairly flawlessly.

So it is probable that the drivers for the onboard card are now been maintained within the “crazy cats module”. Demuxing and hardware based video decoding seem to be working with the onboard dTV card.

Seems its all approaching ready for prime time.

Update: The only serious lingering issue I have come across is getting stuck on DVB-T mode. If this happens to anyone they can clear it be reinstalling the modules addon.



From where downloaded?


The standard libreelec repository.


How to update driver module ???


Just go to the standard libreelec repository and go down until you find the “LibreELEC DVB Drivers”. Click on it and select the upgrade option.
Once installed - make certain that you run the addon and select “Crazy Cats” module. This will need a reboot to take effect.

There is a suggestion that the lingering issues with the dTV card may be due to problems with the current Tvheadend server as they seem to effect other dvb-s cards on different boxes as well.



Hello all,
Last night I discovered something about my setup which makes me have to correct most of what i have said so far. Almost all the improvement in my systems performance is attributable to my HDStar USB card picking up almost all of the duty. Take it out of the system and the dTV card still locks up decoding channels and keeps forgetting the LNB setup. It works well streaming to external TV boxes, but not on the VIM2 itself.
So the driver for the dTV card has not been improved as I thought.
Combined with this is an extremely buggy version of Tvheadend which fails to keep track of the cards and frequently drops connections.

Sorry but the dTV driver is as yet unusable as a single card system. I am thinking about disabling it entirely as it frequently interferes with my HDStar card which is working reasonably well.




Can not configure LNB UNICABLE?


It seems a revision two has been released on the dTV driver. I got it by installing LE 8.90.6.
Solves the getting stuck on dvb-t so now allows you to switch between dvb-s and dvb-t without crashing. Unfortunately still has issues with streaming and HW acceleration. Works with software decoding, but all but the lowest bitrate streams become jumpy after a short time.

By the way, LE 8.90.6 has jumped the Kernel to the new amlogic 4.x which seems to have brought a boost to video playback quality.

Update: Ensure that refresh rate adjust is set to always as this cures most of the playback issues. Still some SD channels seem a bit jumpy but this maybe a problem with low quality feeds.