DVB/DTV Extension Board for VIM2 (VTV)


Hello, I installed LE 8.90.6, I scanned DVB-C and DVB-S with oscam and it works correctly as streaming but locally displays the image for a second and freeze. Something can be done, I installed something wrong on the drivers … since it scans correctly.
Local media works perfectly including Bluray.


These are issues with the LE 8.90.6 rather than the dTV driver. You need to mess about with the various settings to get it to work. I set the amlogic HW decoding to on but set mpeg2 to HW decoding above HD, all the rest were left as HW decoding. Also You need to set the fallback refresh rate to 50hz on the GUI. I also set the adjust refresh rate to always on mine.

I have found that the first channel grab is unreliable and often freezes - but the next one is better. So try opening a channel and if it freezes try another channel (preferably a HD channel). Once it has the first channel it generally settles down after that. You need to experiment with deinterlacing to see what works best.
Channel change is slow in this build whatever the settings. Still I am getting satisfactory performance on most material. It seems to struggle with SD channels more than HD for some reason. It is happy to switch from DVB-t to DVB-s and back again without issues which shows that the driver is maturing all the time.

All these issues are discussed over in the LE thread, and they should mostly by resolved in release 8,90.7 which should be along in the next few days.



Setting up with refresh 50hz I did it from the beginning, the SD and HD decoding settings hw and sw do not know how to do it (depending on the mpeg2 or h264 codec).
I was surprised how right it is to work on decoding the stream, and go to three different channels simultaneously in mac mac x open with two vlc and vlc web plug in safari.

Thank you, I’ll wait for the next version.


If you have got to that bit then you just change the setting on the first item mpeg2 to “On HD and up”.
There are definitely more issues with the SD decoding on this build and setting mpeg2 to software decoding for SD channels with this setting seems to sidestep those issues with minimal impact on performance.
I found that setting deinterlacing was important for smooth HD playback, but the CPU ran out of steam on most content and caused skipping. I set the govenror to “performance” to squeeze a little bit more grunt out of it and it seems to work.
There are still random glitches after channel changes with playback, but mostly its acceptably functional at this stage.



I discovered where the hw decoding is activated and I played SD and HD when I activate hw regardless of HD or SD channel I have black image, it does not decrypt hardware.


I do not get that, how long are you waiting for the image to come in. I have experienced delays of 30secs or more before the image comes in. I usually switch away to another channel at that point and then switch back whereup it plays the HD.



Hi guys, how is this going? Can someone do me a summary of where we are now?

Should we install LE 8.9 or 9.x? Can someone do a summary of what we should install to make it work?

Thanks, Isidro.


There is a new development version called Coreelec. This is worth installing as most things seem to work OK.
They reverted to the old Kernel for stability sake. They also reintroduced installtointernal.
There is still a problem with channel switching but this can be circumvented by:

  • allow hardware acceleration
    -set mpeg2 to HD and up
    -set other two to always.
    -after a reboot always start streaming with a SD channel (software decoded) which wakes up the graphic stack. If you start on a HW accelerated channel then it freezes.

At this stage its usable - but not perfect.



Let’s see what can …


not good when all the bits are hanging out of an expensive board.


Its relatively easy to reconfigure the original case to accommodate the DVT board.



New official CoreELEC 8.90.0 version has full VTV board support with hw acceleration. Also there is iptv playback fix.
For Khadas RC unpack khadas_rc.zip to /storage/.config or to Samba share Configfiles.


@afl1_1 Just built the image (commit 5029e89) and running with the gxm_kvim2.dtb but TVH shows only the DVB-T adapter (DVB-S2 is missing). Any idea to check?



This new CoreElec needs to be built ?
Its not a standard Libreelec tar file and will not uncompress into one.
OK just saw that the new builds have been put up:



Me too. TVH shows only the DVB-T adapter (DVB-S2 is missing)


Which specific version ?
I am running this version:https://mega.nz/#!OCpgQLZb!KW_ZZdpBaUp70feISFlzcSVXQr5iT06skmsWWqIjMXo
and I am getting both dvb-t and dvb-s. This version is the last one available before Coreelec 8.90.0 was released.
Have you installed CvH crazy cats module ?



Wow. This image. Work fine for me.


Which specific version ?

It is master branch from coreelec repository (please, push the repository tags too, in order to keep commit checkpoints.):

Have you installed CvH crazy cats module ?

Crazycats module installed and same result with VTV (just the DVB-T adapter) but remote is disappeared.


Wow. This image. Work fine for me.

Please, could you post the dtb image you are using with?


The dtb.img should be the VIM2_dtb.img image in the dtb folder in the installed SYSTEM partition. Delete the one installed, move the VIM2_dtb into its place and rename it to dtb.img

Have not tried the latest CoreElec 8.90.0 yet but cannot imagine that afl1 has not checked that the full functionality is present in the latest build.

Update: can confirm that DVB-S and DVB-T are present and correct. Everything working fine on CE 8.90.0