COMPLAINT - latest EDGE- firmware [Edge_Pie_V191205]

Brother, the mobile phone itself is a vertical screen, of course, there is no such problem.

First, make sure your board can connect to your computer through USB cable? That is, file transfer.

1 Like

Brother, the mobile phone itself is a vertical screen, of course, there is no such problem.

It also works in landscape mode with no issue. Khadas is the only box I have had this problem within 5+ years.

I have enabled usb debugging as per and then ran the command as above. I don’t know what else to do… How do I enable a usb connection with the box?

Continuing the discussion from COMPLAINT - latest EDGE- firmware [Edge_Pie_V191205]:

Maybe for a short term solution, you can try a rotation app from the Play Store?

Also already included in Android Pie to set rotation for certain apps.


Thanks, I can take a look but ive already tried to change the screen rotation settings, it doesn’t work…

I mean your phone screen is vertical, and your HDMI screen is horizontal. Instead of rotating the screen horizontally


So you have the box powered on, then USB-C -> USB-A to your computer? I have just tried this, no option to do ‘file transfer.’ Can I not just plug the box into my computer…?

You’re assuming I’ve done this before, I haven’t.

NO,NO,I just want to make sure there are no problems with the USB port, USB cable and computer driver. If you can do that, then the rest is ADB.

1 Like

ok, well to start im running Linux, not windows… drivers shouldn’t be an issue as long as ADB and android-tools are installed I think…

Maybe an easier solution… Are there any otther recent firmware that dont have this issue?

No any otther recent firmware , This is the easiest way. Have you never used an ADB before?

ok. No not used ADB before but have used linux command line. if you can guide me to connect the box and give commands, i can do that easily

It doesn’t matter if it’s not used. You can find the Linux ADB on the Internet. It’s not hard to have a lot of information on the Internet.

1 Like

you dont have any khadas guides? Is it possible to just connect this box with usb to use adb?

sudo systemctl enable adb-khadas.service
Failed to execute operation: No such file or directory

$sudo apt-get install adb
$sudo apt-get install android-tools-adb
$adb version
$adb devices

Thanks for your help.

I have found a solution and used;

adb connect <box_ip> to connect to the box. I have copied the file over to my PC as per your instruction and made the edit to build.prop

When I try to copy the file back with;

adb push /home/ubuntu/xxx/build.prop vendor/build.prop

i get the error;

failed to copy '/home/ubuntu/xxx/build.prop' to 'vendor/build.prop': couldn't create file: Read-only file system

I have tried sudo but it still does not work…


adb remount fixes this. For anybody else reading this thread.

frameworks/base/core/res/res/values/config.xml and device/rockchip/rk3399/common/overlay, device/rockchip/rk3399/common/tv/overlay etc.
Check all the config.xml files
set config_enableWallpaperService to true instead of false

Thanks for this post. I’m unable to locate the files or even the folders you’ve mentioned here though, even using find. Could you point me in the right direction please? I’m using ADB / Linux…

Continuing the discussion from COMPLAINT - latest EDGE- firmware [Edge_Pie_V191205]:

It is actually in the source code to build Android.
So will have to rebuilt firmware with it.
My firmware has the change added but it’s AndroidTV layout not AOSP, phone layout, so other launchers might not work.
You can check if this app has the same problem, running sideways, it’s fixed in my firmware.
But I think my patch might cause problems for Khadas’s portable screen that needs rotation.

Here is my latest AndroidTV firmware. Can only use Google Launcher but all apps run landscape.

You can also try this older firmware of mine, it has the same layout as Khadas firmware, but it doesn’t contain the latest changes. But apps should run landscape correctly.!BUciFAxK!eZwQ8RkXz-k0u_V0mVm4QldlDZ4l2mjpSiHHnGpXzDk

There is also an easier way if you just want to change the DPI from 280 to 240.
Root Android with Magisk and then issue in an Android terminal app a command to change the DPI.
Maybe something like
setprop ro.sf.lcd_density=240 or setprop ro.sf.lcd_density 240
Maybe you don’t even need to be rooted.
I think in Developer Settings there is also a setting to change the DPI, I will search for it.
Tap 7 times on build info in the About screen to activate the Developer Settings.


Hi, thanks for this reply and apologies for my late response.

I have had made some progress with the instructions from the dev above. Now the only real issue that I have is that I cannot drag/drop app icons from the app drawer and i cant create new widgets. I would be happy if I could just fix these things which probably fall under one setting.

Do you know how to do this please?

you mentioned that its within the built image somewhere and I’m pretty sure ive mounted .img files in Linux before… Perhaps I could do this and save the changes, then burn the new image… Not sure about it though.

I would be very handy if it could be fixed in the same config file as the screen rotation setting. Could you please guide me how to do it, however it needs to be done?

Thanks for your offer of a modified image but my opsec doesn’t allow for installing software from unofficial sources… no offense but i see it as an attack vector and you can’t trust anybody on the internet unfortunately.

Thanks for your reply and time.