Can not get VIM3 into upgrade mode

Hi All.
I used the search function to find an answer to this but no luck.

I am trying to upgrade the factory Android on my VIM3 to the latest version to get touch screen support etc. but after having tried all 4 ways to enter upgrade mode I am stumped. I ran the various tools/burners etc. and followed the instructions but nothing I tried will initiate upgrade mode.

When using the USB upgrade mode should I also connect the VIM3 to 12 volt external power? I’m a bit nervous about doing this as I don’t want to burn the board.

Any info./help is appreciated.

Hello, I have flashed the VIM3 about 10 times, flashing is usually pretty straight forward.
Just to know where we are starting, your VIM 3 has a working Android on it now? It functions normally?

Thanks for replying.

Yes, my VIM3 has factory Android and it and it functions normally. I’m tring to upgrade to the latest version

I disconnect USB accessories, otherwise connections required to flash are the HDMI cable and a USB-C to USB-A cable, the VIM3 will take its power from the USB of the PC.
1.) Install the USB Burning Tool on your Windows PC(Linux tools are also available).
2.) Download your desired and appropriate firmware image. The downloaded file will be compressed, extract(Unzip) the file.
3.) Open the USB Burning Tool and load the firmware image you extracted in step two.
4.) Connect the USB-C cable to the VIM3, connect the USB-A end to your PC.
5.) Press the Function button, aka the middle button, 3 times in under two seconds.
You should see something like this…

If the rapid Function(Fn) button presses fail, just try them again.

1 Like

I did the steps exactly as you described and what I got is the blue LED on the board did three sets of double flashes and then all LED’s want out and no output via HDMI to the screen. The board seemed to be inert. It did boot up properly when I used the power key to re-start it. I don’t think I am getting a connection to the board as my PC does not show any connection to it. I bought new ‘HI QUALITY’ USB-C cable to use with my VIM3 and am wondering if this is the problem…I tried the process you posted with the USB-C cable plugged into every USB port on my PC but no luck. Anyone have any ideas?

Tomorrow I will go out and look for a new USB-C cable to try as I am hoping it is a simple as that.

Thanks for the detailed reply RDFTKV.

From the way you describe the LED, you are successfully entering MASKROM mode.
Certainly could be the cable. Some cables don’t have a data function. Also, if your VIM3 is cased, I have heard of situations where the case prevents the cable from fully seating in the port, resulting in a loss of data line connections.

I look forward to your findings. Keep us posted.

I’ve also sometimes had issues with the board not showing up in the amlogic burning tool. Uninstalling and reinstalling the tool seems to fix that one. Might be worth a try as well?

1 Like

@Donanon Hello.

  1. You don’t need to use external power. And you can’t use HDMI.
  2. Try to use tst mode . This works no matter what firmware is on the board.
  3. You can try reinstalling your burn tool.

Thanks for replying Frank but I am confused.
If I can’t use HDMI that means no screen connection and how do I control the upgrade process if I can’t see what is happening with the board?


  1. You can use HDMI after upgrade it . But If you use HDMI went upgrade. Ii would failed to into upgrade mode becase it don’t have enough power to brace HDMI.
  2. Even if you use HDMI, there will be no output to HDMI when upgrading.
  3. You can check the status of the board through the burning tool, and the status of the board will be displayed on the burning tool.
    So , I think you should try again without HDMI.

So if I understand this correctly I should connect my VIM3 to my PC using a USB-C cable and upgrade over that. The problem is that my PC does not recognize my VIM3 over the USB-C cable so tomorrow (Monday) I will buy a new USB-C cable to try the upgrade.

I got it to upgrade! The stores are all closed so I went to my storage locker and rooted around until I found a USB-C cable and used it to replace the new one I was using and it worked first time I tried.

Thanks Forum for all the help.


@Donanon Ok, It seems that your data line has no data transmission function.

I have come to a situation like this, where I am not able to put my board on upgrade mode with all the possible options.

Here is the boot log.
There is no HDMI Connected and still it shows LCD resolution error.
I have vim2 which enters the upgrade mode fine and I can see it in the burning tool but vim3 is not, I have tried TST method, Power Key method and also Maskrom method.
Still no luck.

hi, can you boot into Krescue with sd?

Tried but no luck.

The boot log is the same with krescue sd card in the device.

and what are the LEDs on the board?

white only,
While when I press function 3 times its blue and then white.

I’ve tried shorting the M key. But no luck with that also.

Does the USB Burning Tool detect the board?

No it cannot find the device on burning tool, but with same cable and same port it can find vim2 without any problem.