Cannot get VIM3 board to boot into anything other than the stock Android

Which Khadas SBC do you use?

Vim3.**

Which system do you use? Android, Ubuntu, OOWOW or others?

**Currently on Android but want to move to Ubuntu.**

Which version of system do you use? Khadas official images, self built images, or others?

**Trying to use Khadas' Ubuntu images.**

Please describe your issue below:

`**Hi guys, was following this thread because it held a very similar problem but the suggestions there did not help me (Can not get VIM3 into upgrade mode).

Been using TST to try and do anything but Android will just boot with any bootable drives plugged in, I have tried using uboot and OWOOW rescue to launch another image. But not been able to do this.
Tried to use the USB burning tool but that also did not work as kept getting errors when only getting 2% in failing to erase the bootloader and giving the same error each time.

Any ideas on what I can do?**`

You can try Armbian.
Read the instructions well.

In order to boot Armbian from VIM3 with pre-flashed OS on eMMC you need to:

1. [Download Khadas Rescue tool for VIM3](https://dl.khadas.com/Firmware/Krescue/dump/) and flash it to a spare SD card
2. Insert SD card, attach USB keyboard + monitor or a serial console and boot into Khadas Rescue Tool
3. Choose: Advanced -> eMMC -> Fast erase and Advanced -> Erase SPI Flash (Yes). Go back and select "power off"

Now you can boot Armbian from SD card and install to eMMC the standard way.

Just write any image to an sd-card, and plug it in after erasing eMMC. Then you should be able to boot any image from sd. Except Android to my knowledge.

If you want to install Armbian to eMMC then use
sudo armbian-install

Hi @QuestionAsker

Are you not able to see the triple blink of the VIM3โ€™s blue LED when triple clicking the function button ?

Been looking installiing up to 22.04 Ubuntu Server onto the board, managed to get 20.04 on by following the Krescue method to burn on an image, but 22.04 is causing a bootloop and hitting the function key to get it into TST for Krescue is not working. So currently the board is just boot looping and I cannot get back into Krescue.

I was getting the triple blink but the board seemed to gloss straight over it.

I ended up getting Owoow to work and rewrote the OS from the wizard there so board is all good now.

1 Like