Build vim2 firmware including root support

yes, it is good to do so but it is just my speculation…

It’s got the latest version but what’s full emmc cleaning

something like formatting internal storage :slightly_smiling_face:

Factory reset that’s what I’m doing now

1 Like

If after factory reset you still have the issue, check power supply to insure adequate volts/amps. If you cannot check the PS, substitute with a suitable PS. If you have not done so already, check power cable too.

I’ve done factory reset but I was thinking it could be the cable I’ve got another one somewhere

My vim2 is still restarting or rebooting what is doing it I’ve done factory reset twice now and it’s still doing it I’ve even the power cable but it’s still rebooting or restarting I don’t know what is doing it

You may want to have a look in to Krescue. It has a variety of functions and may help troubleshoot your issue.
If you still have Bootcamp on your Mac and can run Windows from it, you could prepare a Krescue SD card to boot the VIM2 from. After the SD card is prepared, you will not need a PC again to flash firmware to your VIM2.


I’ve never heard of it I ain’t got a clue on how to install it could you help us plus I haven’t got windows on my MAC I’ve got Ubuntu on it now but I could put it back on there because I don’t know how to do it with burning tool Ubuntu

I assume DD could be used in Ubuntu to make the SD card…
" Basic Steps to Boot Krescue:

  1. Download an appropriate image for your device from
  2. Burn this image to an SD card, using rufus, dd or Etcher.
  3. Plug in the SD card, USB-C power, and HDMI into your VIM device.
  4. Boot your VIM device into MaskROM mode (please read!!!).
  5. Use an IR remote control or USB keyboard to navigate the UI menus.".

If you want to get an idea what Krescue looks like in operation, have a look at this video on the Khadas YouTube channel.

What will this krescue do then I’m finding this bit complicated I don’t want to mess my vim2 up I don’t what to do

Don’t worry its very safe, its one of the recommended methods of flashing eMMC firmware,
Developed by @hyphop, I have also tried this and assure you there is no way you could screw anything up, Highly trusted for reliability :+1:

but you have to make sure you follow all the steps before booting the Firmware correctly

Could it be something to do with android what’s the latest upgrade for android do you think that might sort out the rebooting or restarting of the vim2 I can’t remember what android image I put on the vim2 I know it was nougat version 7.1.2,build vim2_Nougat_20190518

Maybe you could try a firmware change, maybe a newer version ?

I’m not a expert on doing this plus I haven’t got windows on my computer it’s a MAC I’ve got Ubuntu on it usually I watched videos on how to do this but there’s not much on how to do this do you know why it keeps restarting or rebooting could it be with something to do with android I’ve got nougat 7.1.2 what’s the latest version for the vim2 would I need to upgrade it to a latest image

I saw the latest was nougat 190518 was the latest available image
Download here

the burning tool is available for Ubuntu too,
read it here:

Scroll below and you can get instructions for ubuntu.

Hope it helps :slight_smile:

When did this image come out this year

nope, 18th May, 2019 19 (rep. year) 05(rep. month) 18(rep. year) so it is 190518

I have no way of knowing what is causing the issue, be it hardware or firmware. Unfortunately, AMLogic has not released new SDK for the S912, so no new firmware exists, as developers depend on new AML SDK to make improvements.

You may want to try superceleron’s custom ROM, it offers improvements over stock firmware.
As you have already tried a different cable(power), and a different power supply, flashing firmware may be the only solution left before hardware fault becomes a consideration.
For testing, disconnect unnecessary USB devices to insure they are not to blame.

specify for us the characteristics of your power supply?