Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


Hello @balbes150 . Thank you for posting the mali-7 image.

How did you build that mali-7 image above? I am trying to replicate your achievement but am unable to do so.



What exactly do you want to collect ? Write down the detailed steps you are taking.


Image Armbian upgrade. 3.14_20180507 and 4.16_20180508.
Images are in the directory “no-mali”.
Pay attention.
These images do not have libMali.

The latest version of Armbian 3.14_20180507 and 4.16_20180508 uses KODI without libMali, so it can run on all s905 and s912 models, but without Appart acceleration.


Looking good, thanks, fun to play with. Sound, emmc & USB seem fine (except no RNDIS nor DVB support). Hope one day WiFi & bluetooth will get passed 4.9 :grinning:


What is the latest image? Is it the one in the first post? If it isnt, Can you put the recommended/latest image in the first post?


I can’t edit old messages. The latest version for today is in “no-mail” directory"


Is it this one?


The latest version is located in the catalog “no-mali”


In the folder no-mali, theres a lot of files. Which one is recommended? Whtas the differece between each one?


Oh hi. Thanks for responding. Actually, I’ve managed to get it working now. Thanks!!


Update images version 5.44_20180515.

Please note that the content of MATE\Xfce has changed. Now there is no KODI in the composition of these images. KODI packages with dependencies are in separate directories on the site. To install them, you need to download all the files from the desired directory and install manually (with the appropriate commands “dpkg -i” and “apt install -f”).



I’m getting an error now. Could I please get some help with it?

I do a git pull from your repo on github, and then I compile with this command:


… and I am getting this error:

Building board/khadas/kvim2/bl21.bin
/home/jojapoppa/armbianbuild/cache/sources/u-boot-amlogics905x/Nougat-Ubuntu/Makefile:925: recipe for target ‘bl21.bin’ failed
Makefile:147: recipe for target ‘sub-make’ failed

Thank you!


What image are you trying to collect ?


Oh hi! Thanks for the reply. Actually, I’m not trying to collect an image, but am trying to figure out how to compile from source… just for fun.

What I found is that the conf appears to be missing for kvim2_config (it’s referenced in the boards/amlogic-s905x.conf).

I’ve tried using a different BOOTSOURCE and BOOTBRANCH in sources/amlogics905x.conf; but to no avail, as they all appear to generate similar errors.



The build system requires proper configuration, which is performed when certain menu items are selected in the GUI. At each step of the menu, the system creates the desired configuration piece for the correct Assembly. Without this, the build system will not work.


Playing with Armbian_5.41.1_S9xxx_Ubuntu_xenial_4.17.0-rc3-next-20180430_server.img with a VIM2.
I cannot get Bluetooth to work: more specifically cannot get a controller available.

I guess the onboard Bluetooth is not surprising, although it does pretty well with

Plugging in a BT-USB dongle seems to be doomed as there is no btusb in the /lib/modules tree.

Any comments on what may be possible welcome.


I added an alternative link to download images from “Mega”!j9QSDQSQ!6WpasOlbZYIInfw6yo4phQ

Unfortunately I can’t edit the first post of the topic, so post here.

ArchLinux + KODI (SD & USB & eMMC)

I just downloaded and installed this on my Vorke Z6 and it works. Thanks for your efforts. Would it be difficult to change the build to use OpenPHT instead of Kodi? I mostly use Plex and would love to have OpenPHT running on boot on the S912 but I cant find an image anywhere (that works). Thanks for your time.


Have you tried these options ?


Unfortunately I tried that and Viesens S912 image does not work, it hangs on the splash screen. I verified it was not just me on the LE and Plex forums. Thanks though.