Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


I tried kvim2_linux.dtb, no difference. Then I tried some of the other dtb, still no impact. Indeed, even if I place a completely unviable dtb.img Armbian boots fine but modprobe dhd always fails.

When running the Khadas server image from emmc I can find no apparent active dtb.img. My vim2 seems to have some hidden dtb that I cannot override!


I once again spent time for check. Source systems VIM2 Max 3\64 (with MultiOS_3_in_1 installed). Downloaded the server image


Unpacked and recorded to a USB flash drive 4Gb. Added dtb (kvim2_multios). Connected to the VIM2 and run. Performed the initial configuration of Armbian. After the VIM2 auto reboot, logged in as root and executed the “modprobe dhd” commands . The module was installed without any problems and wlan0 appeared in the ifconfig output.


Thank you for your ongoing support for me. And for all your Armbian and Amlogic contribution. I will keep trying to find my error.


Image update Armbian 20180323 kernel 4.14.11 . Works wired network, USB, monitor (you can change the screen resolution on the fly). The images are in the "test"directory.


Finally worked out my mistake - I was running the Khadas Ubuntu server image (flashed via USB). Each time I booted Armbian from SDcard in fact I was getting the Khadas kernel & DTB from emmc. Since I loaded your Ubuntu server image (via kvim2-update) I can now test fine.

Thank you again


Image update Armbian_5.41.1_20180406 kernel 3.14 (dir mali6/5.41.1-KODI-17.6).

  1. In this version it is possible to use additional screen resolutions. For this, you need in file /boot/ instead of the standard value to specify the new value. A list of possible screen resolutions can be found at the end of the file /boot/ Please note, not all of these values will work.

  2. There is the possibility of fast editing of the parameters of the command line that is passed to the kernel at startup (without having to recompile the script s905_autoscript). Now these values are in plain text file uEnv.ini. If necessary, you can add your own values or change existing ones.


Your work is highly appreciated, it’s too bad you don’t have more developers that could work with you.


Test image Debian + KODI-18.

To run KODI-18 , you need to perform additional configuration of the system.

  1. you need to remove the package “pulseaudio”
  2. Switch to the test repository (disable all other repositories and enable “test” in the sourceslist file). Then install a new version of libc6-2.27 from the test repository).
    After these steps, you can use KODI-18 as usual.


Add test image Ubuntu + KODI-18.
To run KODI-18 , you need to perform additional configuration of the system.

  1. you need to remove the package “pulseaudio”
  2. Switch to the “bionic” repository (disable all other repositories and enable “bionic” in the sourceslist file). Then install a new version of libc6 from the “bionic” repository).

After these steps, you can use KODI-18 as usual.


Image update Armbian kernel 4.17-rc1 20180420 (directory “test” on the website). Now in the mainline kernel works HDMI, USB, wired network. I won’t reveal all the surprises that should happen in the near future in the mainline kernel.


Can’t wait to see these surprises :slight_smile:


this is very good news !


Upgrade images 20180426 with kernel 4.17_rc2_-next.


Armbian test image with next_4 kernel.17-rc2 + KODI-18 which is assembled in X11 mode (without using libMali).

This is a universal version of the image that runs on the entire line of s9xxx and demonstrates the ability to work KODI without libMali. At the moment there is no sound support in the core 4.17, so the sound does not work at all. Also there is no support for hardware video decoding, I have not figured out how to build a KODI version with X11 + amlcodec , but without libMali. When trying to build with this configuration, I get an error, the system requires libMali. Ie. in the source code somewhere hardcoded the link to amlcodec and libMali. If i’m manage to solve this issue, I think the video can be played without problems up to 4K on all s9xxx without libMali (as it happens in gstplay images via kplayer and gst-play. Welcome any help. By the way, anyone can try to collect KODI (with the introduction of their edits) directly to VIM or VIM2 and immediately check the result.

Note that this image does not work correctly shutdown and restart, you need to manually turn off or restart the system (buttons on the Board).


Added image with kernel 3.14.


It has sound and you can fully test the system. By default, I specifically enabled 720 resolution, because there is no hardware decoding yet. On the S912 in 720p video mode works of course there are slowdowns, but the overall impression is not bad for the first test without optimization. The s905 has more noticeable braking. :slight_smile:

Please note, to switch the resolution from 720 to 1080 (or other variants) you need to edit the script /boot/ . Only then will you be able to properly use the new permission in KODI.


Thank you very much for your work. Excuse me, but I just got my VIM2 and I have seen so many different Armbian images that I am a bit lost. Is there any image that has hardware video decoding, and libmali enabled, for VIM2? I have seen some under the directory “libmali”, but I downloaded one of them and I could not find


For S912 cannot access libMali under Linux. If you want to get hardware video decoding, you will have to use either “libhybris” or kernel variants from Amlogic with decoding support (for example it is in GSTPlay images).


Okay, I found some Libreelec images that use libhybris, but I wasn’t able to locate any OS image with gstplay. Do you have any link? Thank you.


Here are excerpts from the information I sent Nick at the end of winter.

Simply run the image from the external media (in multi-boot mode, as Arabian), the system will start the test with the output to the monitor\TV.

Yes, I picked the image with the kernel from BUILDROOT 4.9.76 20180211. I have the same problem with kernel build when you enable this option. Therefore, to control the system in the image with the kernel 4.9.76 have to use the UART console or connect via SSH. Incidentally. look my way Armbian (MATE GUI\XFCE) with kernel 4.9.76. After initial setup Armbian via SSH, the system works fine from GUI. In the GSTplay image with kernel 3.14, you can control the system from the keyboard. To do this, turn off the USB keyboard before turning on the VIM power. To turn the power on (start system) and after a test video , to connect a USB keyboard to VIM. Or you can start the system with a connected keyboard, and then (after system startup) disconnect the USB keyboard and plug again. After these steps, you can control the system from the keyboard as usual. By the way, the images have a MC and it can be used to quickly manage and edit files. The main conclusion that I made from the work of these images - to play full - screen video on s912-does not require libMali. There is enough hardware support for decoding. I am now learning to collect KODI without using libMali . I am interested to try how KODI will work on s912 without libMali (libhibris) with hardware decoding. Then we can collect KODI for Armbian\LE for s912 without the use libhibris (using the aarch64 mode).

This is a theme with details of using this system on other TV boxes.


Interesting. Then it means that all the UI would run over Mesa EGL software emulation, correct?