Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

  1. USB this version is not working
  2. You can test this version in server mode. Please note, this is a test kernel and it is not intended for stable use.
1 Like

Image update 5.37_3.14.29_20171208.


New image Armbian 20171211 with a light shell IceWM DE.


Is the USB something the Khadas Team is working on? @Gouwa :blush:

I don’t understand the question.

You were saying “USB this version is not working”

According to this thread:

it sounded like USB was supposed to work with 4.14? Or at least in August everyone was waiting for USB support in mainline. I’m not really clear from who… Maybe I should post on that thread instead

At the moment in the mainline kernel has no support for USB on s905X and s912. If you really need this version, you can try a test version of the images Armbian kernel 4.14 in which the USB operates. This version of the kernel are built using a large number of patches from @narmstrong .


A test image with a Ubuntu Mate 17.04. To run on the VIM2 you need to uninstall the dtb file.img. The image uses a generic multiboot. To change the screen resolution, you need to change the script /boot/ (same as specified for images Armbian). The name and password of the user “khadas” , root password is “khadas”.

This image was compiled using script FENIX.


Added a new image 20171216 with Ubuntu Mate 17.04 kernel 4.9.40

Hi balbes150,

The image you build based on this commit? I’ve tried, but the HDMI can’t work well, my monitor resolution is 1080p@60hz, so I modify ‘/boot/’ to 1080p@60hz.

OK. The problem is script /etc/initramfs-tools/scripts/local-top/, maybe need to be removed if enable 0hdmi service.

No need to remove it. I deliberately made the activation of the monitor in two phases. In the first stage is a minimum value (720). In the second stage the resolution is set again with parameters needed for operation (720 or 1080). Many on TV who have no 1080 mode, it is not possible to start the system. Two stages allow to do it on any models with a direct connection and when connected via HDMI adapter-VGA.

1 Like

Image update Armbian 20171226.

The main change is the upgrade packages to the current versions in the network reach.

Thanks for this image Im so close to seeing the desktop. The mate distro hangs at starting Bluetooth service. I did notice this error on booting. Not sure if it has anything to do with it or not.

  1. What model VIM (905 or 912) ?
  2. The WiFi module is loaded ?

Activation instructions multi-boot.

Sorry for the delay, its a 912 model. I’m going to re-format the sd card and try again.

Okay… I am not sure what I did wrong the first time around but I changed the whole way I did everything.

First I downloaded Etcher which works for windows, linux, and Macs.
Then I downloaded another image version ubuntu_mate_17_04_4.9.40_20171216.img.xz

On my SD card I ran this command in terminal to zero everything out sudo dd if=/dev/zero of=/dev/rdisk2 ( Tried this with DU but kept throwing an error from previous try at it ).
Then used DiskUtility to format in Fat32.

Next I used Etcher to put the image on the SD.

There are still Failed loading resources couldn’t tell which. I also noticed that the initial login screen is for Kodi. I entered my pass word 4 times and it just kept cycling back to the login screen.

Finally I clicked on the icon on the top right and switched to Mate… Now I am at the desktop :slight_smile:

Other than the Kodi login not working which doesn’t bother me, I just wanted Linux on it. I can use Kodi on the Andriod side. Now I wonder if rebooting back to Andriod will be an issue. Otherwise I’ll just remove the sd card.

Thanks for your help

I leave for vacation. :slight_smile:
All the questions and answers after the holidays.

Wish you a nice holiday!