Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

Accidentally discovered in the latest version of Armbian 5.67 (VIM2) reaction (sound is added and decreased when the test video is played) control the sound volume in MPV from the remote control from Khadas. I wonder if it’s just me or other people’s as well ?

Tried to run Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.0-rc7_desktop_20181117.img.xz on my KVIM2 Pro (3/32) uboot 2015 from microSD.

No USB at all: lsusb shows two linux root hubs and nothing more. Both my USB keyboards wasn’t detected as well as my USB flash drive.
I had to use USB-UART in order to somehow get an access to my KVIM2.
Another thin is that dhclient doesn’t work for me. The eth0 is up, but wouldn’t get an IP.

Before writing the image to microSD I’ve tried to start my KVIM2 from USB Flash drive, but it failed with error: “alert! label=ROOTFS doesn’t exist”. Most likely it’s because of nonworking USB.

Am I doing something wrong? @balbes150, could you please point me to the right way?
Thank you!

This is a classic mistake. :slight_smile:
You did not set the correct dtb. Now this is done differently.

Just swapped comments with line descriptions from dtb on the vim1 vim2.

1 Like

It was so easy … xD
Thank you!


Another question, please…)
Tried to load Wi-Fi driver (Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.0-rc7_desktop_20181117.img.xz on my KVIM2 Pro (3/32)):
sudo modprobe dhd
sudo modprobe wifi_dummy
both returned: module not found in the directory /lib/modules/$(uname -r)

What’s my mistake? Do I need to manually put something?

At the core of 4.19 while there is no support for Wi-Fi VIM2 Pro and Max. There is wifi only on VIM2 Basic.

Update ver 5.67 20181128 kernel 4.19.2

Update ver Next 20181128 kernel 4.20


Any chance to get Wi-Fi working on VIM2 Pro/Max?
Thank you.

Not until someone creates drivers for them.

1 Like

It’s in place already

Does anyone know what’s going on with mali lima driver, there is Libreelec image using it, is it starting to get usable, any chance to soon have it on Armbian and Vim images?

ver 20181228 (kernel 4.19)

Hello there. I install to emmc armbian (Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.7_desktop_20181228.img.xz) and install kodi. But i have problems with performance. Kodi work to slow. Any idea how i can resolve my problem?

If you need KODI, use Libreelec.

The new version 5.68 20190110.
Updated kernel to 4.19.13.

New image Armbian 5.68 20190110 5.0.0 (NEXT)
The version with kernel 5 works only when launched from USB media.

Update the NEXT 5.71 kernel 5.0.0 20190114 image . Fixed working with SD card.

1 Like

The new version 5.71 20190118.
Updated kernel to 4.20.2.

Good news :slight_smile:

Update version NEXT kernel 5.0.0-rc2 20190118.

Khadas VIM1 Pro has WiFi And BT without any patches.


Update image 5.75

How to start the system from HW to VIM1 S905X. :slight_smile:
Run the latest Armbian image from external media.
Download of media the script.

Unpack and run.
Select the components you want to install.
Wait for the installation to finish.

Copy the contents of the “/boot” directory to a new location (for example, to the "/root"user directory).

Fix references to the libMali library in the “/usr/lib/aarch64-linux-gnu” directory (in the process of the script, these references can not be created, because in their place are other files\links). I do it through MC, copy right from DEB package the necessary links with forced replacement.

Reboot the system.

Copy from the previously saved directory “/boot” to the current directory “/boot” (with replacement) - uInitrd , and the uImage file.
Copy with replacement all files from the directory “/usr/lib/linux-image-next-meson64/amlogic” in the directory “/boot/dtb”.

Download and replace media script s905_autoscript this.

Reboot the system.

Run the command “depmod -a” as user ROOT and reboot the system again (or load the mali module manually).

After these steps, I have earned HW in MPV for full screen video and in the browser began to work without brakes video in full screen from YouTube in resolution 1080. :slight_smile:

1 Like

@balbes150, i’ve been trying to run this script, but i get errors, you can see the log on the forum topic.

I’ve been trying to manually install deb packages in this script, mali and kernel, it finishes installing it, but the system stays the same, it does not revert to 4.19.20.

Yes, finally, i’ve tried it with Midnight commander, it is now installing without any errors, thank you!