Anyone has tried out the 5.10-rcx kernel yet?

I don’t have an environment to build it right now, but Amlogic SoC DRM panfrost is officially in, curious how it goes

@O635789 i didn’t notice that, i’ll make a build and test it later

not a problem, check out my post about building images with just a github account and any mobile device

was specifically made for these kinds of situations :smile:


1 Like

it seems Fenix hasn’t been updated to 5.10 yet, waiting for it to be updated…

The panfrost kernel driver still needs some drm patches to be usable on 5.10 but everything needed is queued for 5.11 and simple to backport. On the mesa side the 20.3 branch is now mature and well beyond the point where you can use it, but there are still some rough edges for Desktop windowing systems that need to be resolved. For a more simple use-case like Kodi everything is working well, including all the shadertoy screensavers and visuals.

So far 5.10 rc’s have been stable for me, I have a frequently rebased (WIP) branch here:


@Spikerguy is this something @chewitt linked that can be used for vim3 testing in manjaro for 5.10 or the problem with 5.10 not booting is something else?

No it is just the kernel Image method that needs to changed with 5.10 onwards.


@chewitt Hello. I tested the latest mainline code on VIM3L and used your patchs. I found that the sound card and wifi can not be used normally, is it normal on LE ?

@Frank it works for me

@chewitt Thanks. There is my test log:

khadas@Khadas:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: G12BKHADASVIM3 [G12B-KHADAS-VIM3], device 0: fe.dai-link-0 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: G12BKHADASVIM3 [G12B-KHADAS-VIM3], device 1: fe.dai-link-1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: G12BKHADASVIM3 [G12B-KHADAS-VIM3], device 2: fe.dai-link-2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
khadas@Khadas:~$ aplay -Dhw:0,0 test002.wav 
Playing WAVE 'test002.wav' : Signed 16 bit Little Endian, Rate 44[   40.809511]  fe.dai-link-0: ASoC: no backend DAIs enabled for fe.dai-link-0
100 Hz, Stereo
aplay: set_params:1407: Unable to install hw params:
RATE: 44100
PERIOD_TIME: (124988 124989)
PERIODS: (4 5)

I will try to debug

You need to set mixer settings too, see:


@chewitt Thanks. I have fixed the sound card problem, it is because I did not configure the name when configuring. But wifi is still invalid, have you patched wifi for VIM3L? it works normally on VIM3.


5.10-rc6 came out yesterday and “calmed down”, 5.10 is in good shape now.

1 Like

I haven’t done anything for WLAN… it probes without any issues

@chewitt OK, thanks. Maybe there is a problem with my settings

See if boots from an SD card with everything working - to rule out a hardware problem.

@chewitt I am downloading, thanks for your help.

Can you advice what config and changes were needed to get the audio to work on mainline?

I don’t get any sound card in aplay -l

I see that you were able to see the card.

@Spikerguy The 5.10-rc6 sound card can work by default, but you need to set the configured name. Otherwise, it will report an error during playback.

diff --git a/archives/filesystem/blobs/asound.state/VIM3L/asound.state b/archives/filesystem/blobs/asound.state/VIM3L/asound.state
index 7619676..115fc8b 100644
--- a/archives/filesystem/blobs/asound.state/VIM3L/asound.state
+++ b/archives/filesystem/blobs/asound.state/VIM3L/asound.state
@@ -1,4 +1,4 @@
+state.G12BKHADASVIM3 {
        control.1 {
                iface MIXER
                name 'TDMOUT_A Lane 0 Volume'
@@ -385,8 +385,6 @@ state.SM1KHADASVIM3L {
                        item.0 'IN 0'
                        item.1 'IN 1'
                        item.2 'IN 2'
-                       item.3 'IN 3'
-                       item.4 'IN 4'

This patch use for fenix.

Hello Dear,
I want to get audio to work on Mainline Kernel on Vim3 first, When I try 5.9.11 I see that it cannot detect any audio card.
Can you advice what all is needing to make audio to be detected, I am using pure upstream kernel without any patch, If there is a need for any patch then let me know.

I also have the Alsa card with the exact same name from the dts while a sound script to set the mixer.

Most important concern for me right now is I am not able to get audio card to be detected by the kernel.

@Spikerguy I try with 5.10-rc6 and 5.10-rc5 .without any sounds patch . I am able to get audio card to be detected by the kernel. But I haven’t tried 5.9.11