Any support for Lakka



I’m new here. Just got a regular Vim.
Just one question, where there plans to bring Lakka to the vim?

Lakka is based on LibreElec and is the officila distribution for libretro to play retro games.
Maybe Khadas should donate them a VIM, they already support a lot of arm boxes.

Movian OS for Khadas VIM?

Honestly speaking, I didn’t know Lakka before, but did at the moment. :slight_smile:

As Khadas team is still small now, so in current stage, we will focus more on following things first:

  • Android OS
  • Ubuntu Mate
  • LibreELEC
  • Better service

As Lakka, we tend to provide necessary support to Lakka developers if possible.


Thanks for the answer.
When Balbes150 his LibreElec build is considered stable, I will merge his sources with the ones of Lakka and see if I can get a working image out of it.


if you have not done so, or seen already, JoKeRz over on freaktab has a version that runs from LE. Works perfectly on balbes150 build of LE for the Vim. link below

[LibreELEC] Run RetroArch on your S905/S905X device!


This RetroArch add-on also works on VIM2, but it requires some updates/upgrades:


Lakka is already working on the Khadas VIM.

Use the following s905 image:
With this vim dtb file here:
And it should boot the same as LibreELEC :slight_smile:


I’ve tried install, but no success. can you explain how to do? cheers


Hi pipoko,



Thanks numbqq. I will try again


Does that S905 Lakka image really boot form SD “as is” without additional patching except dtb change? It does not work for me at all. I can’t eveny see any sign of initial u-boot activity on the serial console.


Hi cftech,

Have you tried these steps? If so it’s the same to boot LibreELEC.


Sure. I can boot other system images made by that way (the only difference is that I’m using dd under linux to write image files to the SD card, but that cannot maky any difference), but not the Lakka.


im still with the same problem. cannot use lakka on sd card :confused: probably im noob :frowning:


Hi pipoko,

Can you boot LibreELEC ?


Yes. If i use libreelec image i can boot. But with lakka i can’t


Hi pipoko,

For Lakka, it’s the same to LibreELEC.Just write image to SD card and replace the dtb from


Yh. But i did it. Changed name to dtb.img and lakka didnt start. I dont know why


Hi @pipoko, @cftech

I have built an EMMC installtion Lakka image. Can you try this image? You don’t need any modification.


Thanks numbqq . Use with sd card. Or by USB? Cheers


Hi pipoko,

Please refer to Upgrade Via a USB-C Cable