Alternative to M2X extension Board for connecting SSD NVME M.2 2280 without replacing or extending the enclosure case Khadas VIM3

I propose to discuss an alternative to the Board M2X extension to connect SSD NVME M. 2 2280 without replacing or expanding the case for Khadas VIM3. The idea is to preserve the compactness of the monohull device. Original case. And connect SSD NVME M. 2 2280 drives as an external accessory.

Here is an example adapter https://letyshops.com/r/aliexpress-cotmjsip5ag4c.

Dear developers, users and SELLERS of these devices and adapters. Can I use this adapter for these purposes? If from whom the that the tickles, like would video or photo proof of.

The extension cable should work (as an extension) but I do not think it can work with the current VIM case. The NVME connector is on the underside of the board (where there is limited vertical space) so to avoid folds (which require space) you must route the extension cable via the opposite side of the board where the cable will obscure the power/function/reset buttons. If you fold the cable to route it via the nearest edge it’s a tight fold (risks breaking the cable) and the case (which is not designed for extension devices) does not provide space around the board edges to pass the cable - you’d have to grind the case with a dremel to make space. Even if you get that far, there is not enough vertical space in the topside of the case to house an NVME drive.

TL/DR; the current VIM case is not designed for anything but a board + heatsink/fan combo. You’ll need to 3D print something larger to house an NVME drive, and if you’re making the effort to do that you might as well design a case that doesn’t need an extension cable.

1 Like

I insert nvme directly to vim3
I switch usb/nvme on setings in android
Reboot
But i cant see this drive in android
That can i do ?

Именно для понимания функционала и назначения данного разъёма я и задал этот вопрос в первую очередь разработчткам Khadas VIM3. Как здесь уже писалось, вам ПОКА (разработчики не открыли все тайны), как и мне отсаётся купить их плату расширения. Я покупал в ожидании получить уникальный медиа компьютер с возможностью установки как более игровой системы Android, так и более серьёзных систем на базе Linux. Потратив УЖЕ $220, я ПОКА не могу сказать, что удовлетворён. Понятно, что система свежая и она дорабатывается, но хотелось УЖЕ в базовой версии иметь ПОДДЕРЖКУ SSD M.2 Очень надеюсь, что это не аппаратное ограничение, а недоработка операционой системы и драйверов. ЖДУ ОТВЕТА ОТ РАЗРАБОТЧИКОВ.

It is to understand the functionality and purpose of this connector, I asked this question in the first place razrabotchtkam Khadas VIM3. As it was already written here, to you YET (developers have not opened all secrets), as well as to me it is supposed to buy their expansion Board. I bought in anticipation of getting a unique media computer with the ability to install both a more Android gaming system and more serious Linux-based systems. Having already spent $220, I can NOT yet say that I am satisfied. It is clear that the system is fresh and it is being improved, but I would like to have support for SSD M. 2 IN the basic version. I really hope that this is not a hardware limitation, but a defect of the operating system and drivers. WAITING FOR AN ANSWER FROM THE DEVELOPERS.

Hello, I have done this. Connected NVMe drive directly to VIM3 and it worked.
I used kbi to switch to NVMe. Tonight I will try it using the setting in Android. Will post results when done.

@profd
Update: I was not successful using the setting in Android. I am using superceleron’s Android Pie(normal). The setting does not stick.

I am successful in switching from USB3.0 tp PCIe using a serial tool and the kbi. Using the guide here.

SSD must be an NVMe drive and not an M.2 SATA drive.

1 Like

I switch to pci-e over kvbi
But not see nvme storage in android
I use this model
https://m.ebay.de/itm/SK-Hynix-HFM128GDGTNG-83A0A-BA-BC501-NVMe-128GB-SSD-Dell-0VGN9P-VGN9P-2E/153674628768?ul_ref=https://rover.ebay.com/rover/1/707-53477-19255-0/1?icep_ff3=2&pub=5574735181&toolid=10001&campid=5336086427&icep_item=153674628768&ipn=psmain&icep_vectorid=229487&kwid=902099&mtid=824&kw=lg&srcrot=707-53477-19255-0&rvr_id=2140281076835&rvr_ts=b96e4be416d0ada3c1805b8efffc430e&_mwBanner=1&_rdt=1&ul_noapp=true&pageci=a39ad4ba-537e-4b58-b578-ab96c480d193

In pc it detect as pci-e nvme

What firmware version in on your VIM3?

I used a Patriot Scorch M.2 2280 128GB PCIe 3.0 x2 with NVMe 1.2(PS128GPM280SSDR), worked without issue.

I try two version oficial android and superceleron android.
I cant see nvme.
What type of diskpart i need gpt or mbr ? Fat32 or ntfs ?

I think I formatted the NVMe drive to NTFS or Ext4.
If you are connecting your drive directly to the m.2 connector, make sure the board is parallel with the VIM3 PCB, and not at an angle.

I try ubuntu.
And on boot mesages i see io error initiate nvme
Cant read nvme
I think this model nvme cant work on khadas