5.7x version issues

I could not delete emmc and flash it on pc. usb burn tool has failed. I don’t know how to load the system via sd card.

that is, the system is booted but it is opened on the sd card. Not from emmc. Does uploading this image to emmc fix these problems?

Yes, you can also write the SD card image to eMMC to fix the green screen issue.

Just one command to write the image to eMMC:

$ sudo emmc-install

yes i managed to install. Green screen problem is gone.

The problems I see

  1. The fan does not work. (Very serious problem. Overheating and card may burn;) hard)
  2. Wifi is unstable. For example, I connected to my modem’s wireless network. But it doesn’t see my Routure’s wifi network at all.

Which image you used?


This image both fan & wifi should work.

The fan is work on auto mode.

I used this. and the fan does not work. By default, automatic mode is selected. But the fan doesn’t work. I change the options manually but it still doesn’t work. Do not even want to save button comes out I’m saving. but when I restart it goes back to automatic mode.

Wifi is working. But the router doesn’t see my device at all. But he sees the modem’s wireless network. I can connect to it.

I am using version 5.7 rc7. and I was able to upload it to emmc.

Will the XFCE version of this version be released? Because that version is lite and faster. and I think it should be set to flash from the computer. This method is much simpler.

edit. I noticed something. Icons of all programs installed by Khadas do not appear in the application menu. It looks transparent. For example, I open the HDMI resolution application. There is no list, it is empty.

I checked on my side, the FAN works.

FAN control in /boot/env.txt doesn’t work for 5.x kernel now. The FAN works always on auto mode.

And the trigger temperature is 80 Celsius. Are you sure the board temperature is higher then 80 Celsius? So the FAN will not work unless the temperature is higher then 80 Celsius.

You can check the temperature like this:

$ cat /sys/class/thermal/thermal_zone0/temp

Anyway, you can trigger the FAN to work manually like this, but the FAN will stop if the temperature is not high enough.

  • LOW
$ echo 1 > /sys/class/thermal/cooling_device2/cur_state 
  • MID
$ echo 2 > /sys/class/thermal/cooling_device2/cur_state 
  • HIGH
$ echo 3 > /sys/class/thermal/cooling_device2/cur_state 

You can use such commands to check whether the FAN works.

I’m not sure what you mean. I can connect the AP on my side.

Yes, such applications should be removed, 5.x kernel don’t need these applications.

How can we set 80 to 60 or 65? I want to change the automatic operation limit of the fan.

I think I found the problem. Khadas cannot detect devices broadcasting on channel 13. I made the broadcast channel auto and it became 11. Then he started to see.

and you’re right the fan is working. But it should exceed 80.

Yes, it’s easy.

$ sudo -i
$ echo 60000 > /sys/class/thermal/thermal_zone0/trip_point_3_temp

Setup the trigger temperature to 60 Celsius.


I followed this instruction and it works until i reboot the machine. is there a way to set this threshold permanently?

I suggest to make a small bashscript in the root directory with that command,

then add the command to execute that script in

it should automatically set it at device start up :slightly_smiling_face:


I’m trying to set the tripping point for the fan but I’m getting permission denied (as root) kernel 5.10.5-1-MANJARO-ARM


Edit it with nano or vim it will be fine.
Echo is not allowed i guess.

Even with vim I didn’t allow me. I get a warning that the file is read only and when I try to force write it I get E514: write error :frowning:

That’s weird, i was able to edit it with sudo vim or sudo nano.

Weird, sys fs seems to be ok, according to mount:

sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

I have colling_device0 to 3 and thermal_zone0 and 1 inside /sys/class/thermal (no idea what’s the difference)

-r--r--r-- 1 root root 4.0K Jan 24 11:53 /sys/class/thermal/thermal_zone0/temp
-rw-r--r-- 1 root root 4.0K Jan 24 11:53 /sys/class/thermal/thermal_zone0/trip_point_3_hyst
-r--r--r-- 1 root root 4.0K Jan 24 12:38 /sys/class/thermal/thermal_zone0/trip_point_3_temp
-r--r--r-- 1 root root 4.0K Jan 24 11:53 /sys/class/thermal/thermal_zone0/trip_point_3_type

I tried changing the permission to 644 and after that got input/output error.

I can, however, modify trip_point_3_hyst fine.

I have the same problem. I change the write permissions, but when I restart it goes back to its original state.

-rw-r–r-- 1 root root 4096 Jan 25 20:17 trip_point_0_hyst
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_0_temp
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_0_type
-rw-r–r-- 1 root root 4096 Jan 25 20:17 trip_point_1_hyst
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_1_temp
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_1_type
-rw-r–r-- 1 root root 4096 Jan 25 20:17 trip_point_2_hyst
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_2_temp
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_2_type
-rw-r–r-- 1 root root 4096 Jan 25 20:17 trip_point_3_hyst
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_3_temp
-r–r--r-- 1 root root 4096 Jan 25 20:17 trip_point_3_type


Maybe something changed, according to the kernel documentation that parameter is read only: https://www.kernel.org/doc/Documentation/thermal/sysfs-api.txt:

    The temperature above which trip point will be fired.
    Unit: millidegree Celsius
    RO, Optional

That value should should probably be set in the dtb. Here maybe: meson-khadas-vim3.dtsi « amlogic « dts « boot « arm64 « arch - kernel/git/stable/linux.git - Linux kernel stable tree ?

How can we solve this problem? Because when you open two pages in mozilla, the temperature reaches 80 degrees.

When I look at the chmod settings, I don’t see any strangeness. I even change the file to 777, but in vain! When you reboot the system, everything is back.

@Spikerguy @Electr1 @numbqq

I remember I once was able to give a person a dtb replacement that reduced the trip points, not sure if it applies here but its something to try I guess ? :man_shrugging: