3rd-Party Ubuntu ROM for Khadas VIM


Two test image with different DE - XFCE and MATE.


Balbes, i have installed your xfce image as you advised, thermal readings are better, system is overall much stable.

But, i did lost my wifi connection, i don’t know if i accidentally deleted some package, tried to restart network manager, nothing helped.


Wi-Fi in my previous images worked ?

p.s. Today I got VIM in the near future I will be able to find out for myself. :slight_smile:


I reflashed the image, last night wifi was working, today it doesn’t work.

I am starting to believe that it ain’t my fault, i didn’t do anything that could cause wifi problems, i really don’t understand why this is happening.

I forgot to mention that it worked in your multi de image for few days, and yesterday stopped.


If I understand correctly, You overwrite on the media system from the new image. That means You now are using a different version of the system. Write the name of the image which was previously (which worked WiFi) and write the name of the image you use now.


Older image was s905x Ubuntu 16.04. xenial desktop with Multi De(Icewm, lxde,xfce…) with Mate as default, i am not at home so can’t check the correct name.

New image is s905x Ubuntu xenial desktop 16.04 cpu_over with xfce as default De, the one you suggested me few posts above, you have uploaded it two days ago.

I must say that even in the first image wifi stopped working, but it did work for a week, this one stopped after first shutdown.

If it means anything, i am using win32 disk imager on win10 for creating bootable sd card.

I did use for a while dual boot on my older desktop pc, win7 with Ubuntu or Mint, that pc isn’t with me anymore but luckily it still works, i totally forgot how Linux can be a pain.

I am telling you this because i remembered how i sometimes wanted to hurt myself so badly:), after i couldn’t solve some stupid error, and i really wanted and still want to learn Linux terminal and all things Linux related.

After a while i stopped using terminal as much as i could, and then everything was more or less fine, this is why it works even now.


That is great news. I think your going to enjoy the VIM. I’m guessing your looking for a heatsink and fan about now.:slight_smile:


If the Wifi worked on the multi-DM, and then ceased to work in it, then the cause is most likely not in the software. Perhaps You changed something in the router settings or it ceased to work Wi-Fi. Have you tried to restart the router ?

I hope soon to write a small report about what I have done with VIM. My first impressions were rather interesting device, the first thing I liked - the design principle of the modular housing (its easy to change with minimal cost). The current design needs some work, but it’s easy to do.


I didn’t change any router settings, but i haven’t tried to restart it.

I don’t have any problems with wifi on my phone and Android Os on Vim, but maybe it would work if i restarted it.


One question, when you create bootable sd cards, they are formatted as fat32.

Is it possible to use it in ext4 format, and would you have any benefits with it?


First partition is FAT32, unseen from a Windows PC is the second EXT partition (rfs).


Yeah, i googled it a little later, that’s why it wasn’t showing me whole sd size after creating bootable sd.

It was strange to me that the whole card used fat32, i know that Linux uses ext fs.


Need help keep trying this for many days now

Balbes, i have tried to reset the router, it is still the same situation, no wifi.

Everything works more or less well, except this, i hope i won’t have this problem when official Mate comes out.


I checked this running Mate - Armbian_5.24_S9xxx_mate_Ubuntu_xenial_3.14.29_desktop_20170205.img from SD card.

There does seem to be a problem.
The network manager sees the WiFi module(device wlan0) and shows a MAC, but does not see my networks.
Under the notification area, network connections, WiFi is greyed out.
After many attempts to setup the network manager, no go.
Also could not use the WiFi module as a hotspot, shows device wlan0(and MAC), but nothing actually happens
Also will not pickup an unsecured hotspot provided by another TV box.

Sometimes network notification reports eth0 connected, even when no Eth cable is connected.

I think I will download the image again and re-burn the card.


In the next few days I’ll try to check.


Checked the latest image. Downloaded from the website (something to make sure that the file on the website is not corrupted). Recorded on the flash drive. Launched on VIM. Then show a video of my actions. The system found the available network, I enter only a password to connect. Pay attention - I not change Android, I just added multi-upload (via UART console, it’s easier and immediately see the result). The dtb file is used from internal memory. Maybe you have to handle the case could disconnect the antenna or broke the contact. Or use the dtb that is different from the regular one. Either the router is spelled out binding to MAC to the address, and he changed. Ideas from me yet.


Need help keep trying this for many days now

Pay attention, for those who use my images. I found the cause of the fall core at a temperature of 70 degrees in the images Armbian is a module “mali.ko”. Remove it from the system (for old images). On the website under Linux\Armbian\Test an updated version of the image MATE (20170228) with the correction (without the module “mali.ko”) and a few patches that improve the core.

Image MATE 20170205. Removed the module “mali.ko” . Under load (without fan) the temperature reaches 80-82 degrees - the system does not fall, continues to work.


Balbes, are you planning to make a Armbian debian server version? Or a Arch Linux Arm?


Images are downloaded from Debian. After some time they will be available. The version of the image with ArchLinux is on the site, but it has not been updated because no one asks about it. By the way, in the near future (after testing) images from the Test directory will be moved to the main directory, because I have limited place. If anyone needs the old version - download now in the future I will delete (to make room for new).