Write new linux server to eMCC but can not boot

Vim v1.2 1610 49 16
after sucessfully booting ubuntu from
SD card. I used gparted format eMCC to fat32 and wrote new linux server image ( Vim_Ubuntu-server-16.04_V170120.7z) to the eMCC using
sudo dd if=update.img of=dev/dev/mmcblk1
unfortunately writing was not done yet, the ubuntu crashed and I had to rebooted. After that Vim can not reboot anymore regardless whatever version of image I tried to boot(which used to bootable earlier). I tried to erase eMCC many times by long press Function+Power and at the same time short press Reset.
Now when power on,with or without SD card inserted, the monitor keep flasing for 4-5 time.Then everything stops.
any recomment please ?

Where you got the step? what do you mean this step?

just writing new linux image to the eMCC drive. Is something wrong with it ?

correction : it is
sudo dd if=update.img of=/dev/mmcblk1
(only one “dev”)

Happy Chinese New Year 2017 !

1 Like

Where you run this command? on your Linux PC? We don’t have any guidance to write eMMC directly on Host PC yet.

Please follow this guidance one by one to upgrade:

My problem at the moment is when turning on piwer to Vim how to stop flashing of the screen of the monitor. For the process of SD writing image,I had dine sucessfully before.
Please advise. Thank you.

What do you meant here? Please describe your problem with details.

my situation at the moment is whenever I power on Vim (with or without SD ca5d). The screen of monitor is keep flipping(flashing about 5-6 times).Then stops and nothing happens anymore.

Actually, I didn’t understand what do you mean flipping/falshing, maybe a short video can help out.

BTW, why you upgrade with:

sudo dd if=update.img of=/dev/mmcblk1

how can I send you the short vdo ?

can I attach short vdo file to you by email. If yes. please give me your email address.

FYI : I just follow same instructions like in case of SD card.
sudo dd if=update.img of=/dev/mmcblk1

here is the vdo of my “flashing screen”.

Can you advise how to reset back to “factory default” ?
Thank you.

sorry. I just changed vdo to "public"
thank you.

In this case, you need:

Take notice that your DC adapter can supply enough currents for VIM, 5V 2000mA is recommended.

Try it out and feedback to us.

Good luck!

thank you.
once finish boot into upgrade rom as you advised above.
in case I use usb drive for booting(not use SD card), can I use u-boot.bin.sd.bin bootloader ?
have a joinful and exciting long holidays on new year eve.
thank you.

You can upgrade ROM using both USB-C, but there is no need to burn u-boot again!

(Feed back)
had tried MRegister mode as you advised above. But the screen still keep flashing as per vdo : https://youtu.be/Mlqcy8A_pGw
Please advise.

ps. had already changed DC adaptor to 5V 2 Amp as per your notice.