Windows power-saving mode problem with ktb2

Windows 10 is not going to power-save mode when tone board 2 is connected.
Display is always on, no screensaver, no automatic sleep mode.
powercfg /requests command show ‘None’ for all listed items.
When i unplug tone board form usb, or turn it off by long press on volume encoder - everything works fine.
board serial number is 13A1000F, firmware 1.2

Hello, Welcome to the community.
I am curious, if you turn off power saving for the USB port used for the T2P, does the situation change?

Otherwise, the Khadas Team is on holiday until May 6, then they will be able to look in to it.

When I get to the T2P, I will attempt to replicate your issue.

Hello, Thank you for fast reply.
Yes, I’ve tried to turn off usb power saving feature globally in control panel, but not for one usb port, as I don’t know how to determine exact one usb port in device manager. unfortunately it did not help.

I observe the same behavior here. Hopefully Khadas will have a solution for you when they return from holiday.
Good luck.

1 Like

Disable the associated USB HID devices (will almost certainly prevent playback control from the device but I do not care about that functionality and haven’t confirmed it).

They will have hardware ID’s similar to the tone2 itself, for me there are 2 of them - USB\VID_3353&PID_A002<_REV etc>


You are absolutely correct. It really helped! Thank you.

1 Like

Hey, I also observe the same behavior, maybe I see a similarity with the Allo Revolution DAC. They had the same problem with the thesycon driver and firmware and got it fixed.

Hopefully khadas are able to deliver a fixed firmware, too :slight_smile:

Kind regards!

Hey, did you, by chance, hear anything from Khadas?
Indeed the HID device seems to be the troublemaker, like with the Allo revolution dac.

Kind regards :slight_smile:

1 Like

Sorry, I have not heard anything. Perhaps @Eric68 will have the answer.

Thank you for the heads up
@Eric68 I am happy to provide more information if needed :slight_smile:

Hi,Andrey_K, Thanks for your question. I have also tested this situation. I will ask our software engineer for help. Just wait for my rely. :smiley:

1 Like

Apparently, it happened to both TB1 and BenchMark DAC 2 as well on either Windows 7/10. Unplug/Replug the USB not effect. Reboot is the only way to start it again. However, you can try the step below, it works for me.

All I did is change the advance power safe mode of Sleep to “Never”

i’m sorry, did you read the topic?

Have you tried to install the latest windows 10 update? There were many issues happen in the last 2 years and I found out that part of the problem was the windows update as well. Maybe run the last update then Enable the associated USB HID devices to see if it works. I couldn’t recall other issues in the past with windows but it never runs into problem with linux since I have 2 toneboard that 1 with windows and another with linux. The one with windows has more problem so upgrade firmware and driver do fix the problem for windows…

Hey Eric, any news on this topic yet :slight_smile: ?

We have fixed the XMOS firmware,and have solved the problem,the PC can enter the sleep mode when connect to T2P,but we find sometimes this will affect the USB HID,such as stop/next/previous. We need more time to test.


Thank you for the heads up, great to hear you could locate the issue, looking forward to the finished firmware :slight_smile: