Windows power-saving mode problem with ktb2

Hello,
Windows 10 is not going to power-save mode when tone board 2 is connected.
Display is always on, no screensaver, no automatic sleep mode.
powercfg /requests command show ‘None’ for all listed items.
When i unplug tone board form usb, or turn it off by long press on volume encoder - everything works fine.
board serial number is 13A1000F, firmware 1.2

Hello, Welcome to the community.
I am curious, if you turn off power saving for the USB port used for the T2P, does the situation change?

Otherwise, the Khadas Team is on holiday until May 6, then they will be able to look in to it.

When I get to the T2P, I will attempt to replicate your issue.

Hello, Thank you for fast reply.
Yes, I’ve tried to turn off usb power saving feature globally in control panel, but not for one usb port, as I don’t know how to determine exact one usb port in device manager. unfortunately it did not help.

I observe the same behavior here. Hopefully Khadas will have a solution for you when they return from holiday.
Good luck.

Disable the associated USB HID devices (will almost certainly prevent playback control from the device but I do not care about that functionality and haven’t confirmed it).

They will have hardware ID’s similar to the tone2 itself, for me there are 2 of them - USB\VID_3353&PID_A002<_REV etc>

1 Like

You are absolutely correct. It really helped! Thank you.

1 Like