While Loading firmware: Download boot fails error


My EDGE board enters in maskrom mode ane now it is not coming out from it. even not able to load a new image also. getting error like “Download boot fail”.

Please can anyone help me to make this board woking

Execute the red arrow button to see what’s going on?@Jigar

@goenjoy Getting same error if i try to eraseflash option.

@Jigar It seems that the board is abnormal. What happened to the board before? Or you can use the air gun to solder the CPU and DDR chips.

@goenjoy Nothing I was just trying to flash new firmware so I put the board in loader mode and after reboot, board started rebooting so i run Erase flash and then onwards not able to flash new image and getting error like above.

What to do now to recover?

I am not clear about this.
“Or can you solder the CPU and DDR chips? Or you can use the air gun to solder the CPU and DDR chips.”

Send out the serial port log during the upgrade process.

when board boots in MASK ROM I am not getting any data on a serial log.

Thanks.will do this and let you know.