Which is compatible with vim? USB to TTL Serial UART module


#1

which is compatible with vim? USB to TTL Serial UART module
is this okay for the vim?
https://it.aliexpress.com/store/product/Arancione-Pi-USB-a-TTL-Modulo-Seriale-UART/1553371_32844850903.html?spm=a2g0y.12010612.0.0.538469518bKf9

do I have another more suitable?


#2

Hi, qaz22:
Actually, you can choose any standard USB to UART module for VIM, and the link you showed above should be works.

Enjoy!


#3

potrei avere un firmware solo per cancellare mmc con solo u-boot al suo interno visto che mi si blocca sempre al 4% .

grazie


#4

I cannot get any USB-UART dongles to work with Ubuntu mate on VIM1. At least FTDI, pl2303, cp210x, ch341-uart are not recognized (not assigned to /dev/ttyX according to dmesg).

Could somebody list the USB-serial devices that are known to work on VIM1 please? Using Ubuntu mate Linux 4.9 31may 2018.

In case of somewhat similar problems a year ago with amd64 the kernel ugrade from 3.x to 4.13 helped. But at least FTDI was always recognized then.


#5

Do you mean that usb-uart on VIM device not Linux PC, right?

PL2303, CH341 should be support on Linux PC without any driver to be installed.


#6

Yes, tried to use USB UART dongles on VIM1 with ubuntu mate 4.9 Khadas firmware.
N


#7

Hello ufneeme,

For linux 4.9 V180531 doesn’t support well, but I have enabled now,

So if you are a developer you can update the kernel.

If not, you can try linux 3.14 which is enabled.

Thanks.


#8

thanks, 3.14 works for me.

khadas is a perfect thing… there is just one thing I wish - could the display rotation become enabled somehow as well?


#9

found that ubuntu mate 3.14 image has a shortcoming - reboot will hang on some end job.
Is there an instruction somewhere how to update the kernel?
I would still like to try updating 4.9 (even if I’m not a kernel developer).


#10

It’s enabled in mainline linux.

This issue has been fixed. You need to update the kernel.

Please change to V180531 linux 4.9 image. And execute the following commands to update the kernel.

khadas@Khadas:~$ sudo systemctl stop watchdog  
khadas@Khadas:~$ sudo systemctl disable watchdog
khadas@Khadas:~$ wget https://dl.khadas.com/Firmware/test/debs/linux-image-amlogic-s905x-4.9_0.3_arm64.deb
khadas@Khadas:~$ sudo dpkg -i linux-image-amlogic-s905x-4.9_0.3_arm64.deb 
khadas@Khadas:~$ sudo reboot

Thanks.


#11

got an error: :frowning:
root@Khadas:~# dpkg -i linux-image-amlogic-s905x-4.9_0.3_arm64.deb
Selecting previously unselected package linux-image-amlogic-s905x-4.9.
(Reading database … 115775 files and directories currently installed.)
Preparing to unpack linux-image-amlogic-s905x-4.9_0.3_arm64.deb …
Unpacking linux-image-amlogic-s905x-4.9 (0.3) …
dpkg: error processing archive linux-image-amlogic-s905x-4.9_0.3_arm64.deb (–install):
trying to overwrite ‘/boot/config-4.9.40’, which is also in package linux-image-amlogic-s905x-linux-4.9 0.3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
linux-image-amlogic-s905x-4.9_0.3_arm64.deb


#12

after reboot khadas logo is displayed, nothing else.


#13

Ooops, the kernel package name changed since last release. So you need to uninstall the old kernel and install the new kernel.

Uninstall the kernel:

$ sudo dpkg -r linux-image-amlogic-s905x-linux-4.9

Maybe you need to burn the image again…

After you burn the image, try to uninstall the old kernel first, and then install the new kernel.

Thanks.


#14

what is the command for uninstalling the current kernel? (googling gave me answers to remove old unused kernels only)


#15
$ sudo dpkg -r linux-image-amlogic-s905x-linux-4.9

#16

thanks, this helped. 4.9 seems to work fine for me now.

but related to mainline linux (to try screen rotation), I cannot see anything else but pre-alpha server for VIM1?


#17

Here are some test images: https://dl.khadas.com/Firmware/test/

Or you can try balbes150’s Armbian images with mainline kernel.


#18
  1. found no mainline images in https://dl.khadas.com/Firmware/test/, only mate for SD (need eMMC). do not want multiboot (balbes150 forces that afaik).

  2. related to mate 4.9 - is /dev/ttyS4 enabled? cannot communicate with this, but works in 3.14

  3. mate 3.14 image on khadas firmware page has not changed imho, has still the same reboot issue.


#19

pls ignore point2, was my mistake


#20

It’s stable version 4.17. No eMMC image for 4.17 now.

Yes, it’s still V180531. If you want I can provide the kernel for you to update.

khadas@Khadas:~$ sudo systemctl stop watchdog  
khadas@Khadas:~$ sudo systemctl disable watchdog
khadas@Khadas:~$ sudo dpkg -r linux-image-amlogic-s905x-linux-3.14
khadas@Khadas:~$ wget https://dl.khadas.com/Firmware/test/debs/linux-image-amlogic-s905x-3.14_0.3_arm64.deb
khadas@Khadas:~$ sudo dpkg -i linux-image-amlogic-s905x-3.14_0.3_arm64.deb
khadas@Khadas:~$ sudo reboot

Thanks.