Volumio for Khadas


I compiled a test multi-version of Volumio for VIM-1 (s905X) and VIM-2 (S912) and others TV box s9xxx. The system normally runs, allows you to connect a standard WebGUI. Sound working to USB sound cards. But still not working HDMI the sound output. I’m not an expert on sound, so I would be very grateful to those who will help to find the reason why the sound is not working to HDMI. The image can be downloaded from here. While the system works only with SD cards. Be sure to have activated the universal multi-boot.

Source code for building the image.

By the way, along the way I found an error in the profile for Odroid-C2 and assembled a working version with the latest source. If anyone is interested, I can give a link to a working image for Odroid-c2. :slight_smile:

Details about the Volumio system.



GIT Volumio


Please give me this link.
Latest buil for odroid c2 on oficial site have a trouble to play 16 bit 44kh to i2s.


Khadas Staff please help us. We need this system.



Good news. Dug up from a simple USB sound card. Hooked up to VIM and the sound is played through it. This means that the system itself Volumio is assembled correctly and works. Now we have to deal with regular system AML8AUDIO via HDMI. During the inspections found that the sound itself (via direct commands alsa) gives a hiss, then you need to deal with the settings and possible modules\kernel.


The new version of the image. It’s a versatile look that can work for all s9xxx (S905x VIM and VIM2 S912).



It is very GOOD news!!!


Error text when you try to use the built-in sound system (AMLM8AUDIO). Maybe it’ll help knowing understand why, why does not output sound via HDMI.

Failed to open “alsa” [alsa]; Error opening ALSA device “hw:0,0”; snd_pcm_hw_params_set_buffer_time_near() failed: Invalid argument


Discovered an interesting nuance. If you try to play through HDMI system sounds (file “.wav” for testing Alsa), Volumio plays the sound fine, without errors. It’s okay to play system sound through HDMI when running Volumio. It turns out that playback via HDMI works, but lacks some settings or decoders.


I think with the release of the module from Khadas, he will also be able to work well with Volumio. :slight_smile:


The founder of Volumio contacted us for further cooperation days ago, we shipped two free samples for them.

So I think things will move forward :wink:

Rock it up!


Good news!!!
Thank you!

Khadas Tone Board for VIMs

Good news indeed!

I think it will be a good idea to have Volumio working on VIM from the eMMC as an alternative to SD. Running from the eMMC will increase performance significantly especially for those that have really big music database.


We will release eMMC version rom this month


Add a script that will install Volumio in eMMC, it is easy. I still didn’t do it just because it still does not work built-in sound system AMLM8AUDIO.


Hi Guys,
I just have installed Roon Bridge on volumio (balbes150 build) on VIM. It was really peace of cake because of the original Roon Labs script worked directly. You only have to follow the errors and install missing software :wink: Working version is for armv7hf! HDMI sound is working in Roon on first shoot. I will test it more deeply later.


Its look like the hw:CARD=AMLM8AUDIO,DEV=0(or 1) is the proper interface. When i have time i’ll check every single interface reported, one by one. I will attach spdif cable and HDMI to see what is where and whay :slight_smile: This is what i got from volumio for AML audio hardware:

**** List of PLAYBACK Hardware Devices ****
card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.39 T9015-audio-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.40 dit-hifi-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.41 pcm2bt-pcm-2 []
Subdevices: 1/1
Subdevice #0: subdevice #0


Discard all samples (playback) or generate zero samples (capture)
Default Audio Device
Default Audio Device
Direct sample mixing device
Direct sample mixing device
Direct sample mixing device
Direct sample snooping device
Direct sample snooping device
Direct sample snooping device
Direct hardware device without any conversions
Direct hardware device without any conversions
Direct hardware device without any conversions
Hardware device with all software conversions
Hardware device with all software conversions
Hardware device with all software conversions


Easy for you may be :slight_smile: Btw, volumio did not created hotspot to connect and configure it at first boot. Honestly, i did not played long enough to see where is the problem, so may be i do something wrong. But even after installation trough wired LAN i can’t get wireless LAN and hotspot function on.


This image was compiled using the kernel from Armbian, so it is necessary to use the instructions from Armbian. :slight_smile:
For Wifi you need to load the module dhd or wifi_dummy (and prescribe in startup).


I can’t find which file replace or what scrept is writing in /etc/mpd.conf on boot. I need this to test outputs in MPD and not in Roon or Squeezelite. Help please :tired_face: