Voices from user confused

To me your advertisement for the vim is misleading as it suggests that android and ubuntu are both pre-installed. As you know there are boxes and tablets that run dual OS pre-installed so I thought your box was the same sort of thing. So I was not having any unrealistic expectations. In this case it seems to be a case of buyer beware, I was led to believe ubuntu was pre-installed but now I realize that I made a wasteful mistake.

You can see from my first posts that I was trying to get ubuntu running on this box and so far nobody has told me how to do it. So .

In my board everything was pre-installed. It had Android. Then I promptly re-flashed it with Ubuntu, from the firmware page, no problems at all. I expected to have to work to make the board do exactly what I wanted.
Next time you buy something, just a little suggestion: Do your homework first. Read the forums, check what people are saying etc.

Regarding languages, you are right. My first language is Spanish, then Russian and last English. Fully fluent in all of them, been living in the UK since 1998.


From gearbest, where I bought it:

Main Features:
● Android 6.0 + OpenELEC + Ubuntu + Buildroot Multi-OS will bring you surprise of using experience
● Amlogic S905X quad-core CPU is rapid and stable which can give you high-speed feedback and smooth response
● Bluetooth 4.2 connectivity: easy pairing with most Bluetooth-enabled devices
● 2.4GHz / 5.0GHz WiFi: connecting effortlessly in a world without wires

Note: it is pre-installed Android system.

Now, this is what I did to install Ubuntu in the emmc

  1. Download the USB Upgrade Tool and extract it.

  2. Run ‘setup_v2.0.8.exe’ to install the tool for VIM upgrading:

  3. Download the Ubuntu emmc image. I used http://www.mediafire.com/file/7ilichl366nd5z3/Vim_Ubuntu-server-16.04_V170211.7z, there is a newer one, but I have not tried it yet. Unpack the image archive.

  4. Plug your VIM on your windows PC using the USB-C cable. Now put the board in upgrade mode:
    a) Long press Power key without release
    b) Short press Reset key and release
    c) Count 2-3 seconds and release the Power key to enter into upgrade mode

Your PC should have found VIM device as upgrade mode if you correctly follow the above steps

  1. Select the image file and press start. The update should finish successfully.

This is all from http://docs.khadas.com/bootcamp/UpgradeViaUSBCable/

Worked for me. Good luck!


Hello confused, I am not a Khadas team member. The adverts for the Vim put it in the most positive light, this is true for all adverts and for all products from all companies. I and others did not see the Vim as coming with the OSes listed already installed, and saw Android as the installed OS. Yes, dual-boot boxes are available, but they are pretty rare and have varying degrees of functionality. In the future, do your research.

You say there are other, cheaper boxes that just work out of the gate. I have been a serious Android TV box entuaiast for years now. Somehow, I missed the model you are referring to. Perhaps you will enlighten me. Please tell me the box you speak of.
For every box you do list, my guess is I can find a forum full of opinions contrary to your statement. But you may know something I don’t. Looking forward to your list…

It seems you are geared to complaint and not resolution.
When you get past the tantrum, I will help you accomplish your objective, ref Linux. But you will have to drop the attitude and adopt a more positive attitude or we will just be pissin’ in the wind. Anger is counterproductive.

If you don’t have the patience for this stuff, maybe you could sell your Vim to a more inclined individual and buy the 'golden" box you say exists. In the time you have wasted on complaints, we could have had you running Linux by now.
Good luck, I will not engage you further. Though I am still willing to help, I won’t further respond to your venting.

Good day.



I have to say I have been working on our evaluation VIM running Ubuntu and we are very happy with it. We need Docker and USB OTG which last we heard is still pending, but Gouwa has provided a great level of support, especially compared to other SBC vendors we have tried to work with (BananaPi comes to mind.)

Please give Khadas VIM a chance. I think they have got a real winner of a product here that compared better than all of the other SBCs we’ve looked at or tried, including the RPi3 which is just underpowered and draws too much wattage.

1 Like

You can keep your stupid condescending, sarcastic remarks and shove them because I do not need or want your so-called limp help. Also I am not going to “enlighten” you about anything because you think yourself so special, how could I possibly tell you something that you don’t already know or think you already know!
Yes, I already have a “golden box” which runs far more than just one OS. I am not interested in dual boot, I am only interested in multiple boot boxes.

Finally, I don’t wish you to engage me ever again.

Thank you for your reply. I followed the instructions one hundred percent and the burning tool NEVER recognized the vim box, after many repeated attempts, so impossible to insert the ubuntu. Yes I downloaded the burning tool and extracted it. I even created an SD ubuntu card to try and this thing ignored that as well. This has to be the worst box I have ever been stupid enough to buy, it’s crap. I am not having a tantrum or anything else I am merely stating my experience with this junk. Anyway, I have now found some fantastic boards , two in particular. Check out the new Udoo X86. This vim is nothing more than a piece of junk.

Not WOW anymore, you just lost your money.

Another nonsense reply, the burning tool does not recognize the vim at all and neither does the TF card. Who wants stupid libelec, I want ubuntu and at worst android but your gadget is such rubbish it cannot be repaired.
You never answered my last reply because obviously you don’t have a clue what you are doing, just waiting for someone else to come up with a solution.

Black screen and the MRegistor Mode does NOT work at all. More rubbish!

Black screen and the MRegistor Mode does NOT work at all. More rubbish! Nothing works.

My last two replies were for that ever helpful gouva who obviously doesn’t know very much.

This is simply not true, vim will not boot from SD card, in fact it will never boot from either SD card or usb drive. Fn button does nothing. Burning tool is not reccognized. In settings, in “about”, updates do not work and when select is pressed nothing happens. In recovery window selections refuse to load SD card or usb drive. So is this vim broken or what? Can it be returned to your office? Can it be repaired. Can it do any of the things you claim it can do?

You don’t need to answer because the box is now dead, No boot up at all anymore. What a waste of time and money. What a piece of crap.

Can I have your address so I can return the vim for your qualified attention.

Hi, Confused:
You can contact the custom service where you bought the VIM for the details.

So when the vim is broken you people don’t want to know. That’s what I call bull*hit support! Pass the problem to somebody else, lousy support for a crap box.

hello, Confused.
This is Willow at your service.
would you please tell us where you buy the Khadas Vim Board and offer us the buying ID
maybe we can help. Thank you.

Hi, Confused:
I’ve just moved all your comments to a new topic, in your situation, I suggest you to contact the customer service where you bought the VIM for a return.

As you can see, when you posted the problem, many people tried to help you out with detailed steps or instructions, but it seem that you didn’t get a try, and just response with many complaints instead of the details to describe the problem you were facing.

For Khadas Community, any good or bad voices are welcome, but we also need to Be Civil and Keep It Tidy when you post comments. This is the reason I move your comments to this topic.

If you still have any questions, you can contact @willow, she will follow it up.


Actually you are wrong I gave everything a try and ended up absolutely frustrated. First I tried to load ubuntu but that did not happen. Then I continued messing around with the box until I got a black screen. Not a single one of your suggestions worked, Windows never recognized the box ever, so how was I meant to proceed when all you could do was rattle off the same stupid instructions that never worked in the first place. When I first asked for help you simply pointed me at the firmware page which had multiple choices but no explanations, so of course I got it wrong and therefore I was very angry with you because you could not be bothered to explain. Then other idiots here (who never read my first posts) tried to give me the exact same instructions which you did even though I explained already that they won’t work. It is your vim box that is the problem and now it is lying in a box in pieces.
My Windows does NOT recognize your vim box so what am I meant to do? The stupid instructions will NOT work with the box I have/had. Your vim box is simply an expensive gimmick with bad programming.