VNC nor RDP working, help with how to setup on VIM4 Ubuntu 22.04.1

I’ve enabled the remote access options after doing the upgrade to 22.04.1. However I am not able to access the desktop with either VNC or RDP client. VNC just hangs at connecting on the client side, the Ubuntu desktop shows that the desktop is being shared with the little icon in upper right. RDP just give a black screen on the client side.

I am not able to ‘NOT USE’ Wayland. Neither selecting a different window manager from the login screen or disabling it in ‘/etc/gdm3/custom.conf’ will allow you to get past the login in screen.

Both VNC and RDP work on a standard Ubuntu 22.04.1 Intel SBC, both with Wayland on or off.

Thanks for your help!

Have you checked your kernel config, it might need a one or two options enabled.

Hi @foxsquirrel , thank you for the info. What specific would you recommend I look for? And where would I look for these options?


make kernel-config

Do you use fenix?

Thanks for the info. I think you are a couple of pay grade levels about moi :grinning:. It has been many years since I was down the rabbit hole of unix/linux kernel work. I think I will leave this to you young turks. I will just whine, drink wine :wine_glass: and hope for the next version from the smart Khadas folks…

And to show the limit of my knowledge, I am guessing at your question “Do you use fenix?” to mean, am I familiar with the Khadas build system to create Ubuntu OS for their hardware. I looked at in on github and confirmed my limits.


Young, that was a very LONG time ago. :grin:

Its not you, its the ARM stuff is way too messy. We are getting pretty close to making another change in boards and going with something else. The time involved getting a product ready is ridiculous, we have burned up so much time and have nothing to show for it.

Understand your frustrations regarding stuff not working, some of that is Ubuntu and others that keep changing stuff without realizing the consequences of their actions. Pretty sure we are done with Ubuntu on the SBC’s and going with a stable Debian release.

Hello @deepvim

Could you please provide the steps on your side?

Hi @numbqq here you are:

installed vim4-ubuntu-22.04-gnome-linux-5.4-fenix-1.1-220721.img.xz via oowow

sudo apt update
sudo apt full-upgrade
sudo do-fenix-full-upgrade
this last command showed:
E: Unable to locate package fenix-updater-package-jammy-vim4-mainline

sudo reboot

In control panel:
enabled Remote Desktop in Sharing
Remote Desktop is ON
Remote Control is ON
Enable Legacy VNC Protocol is checked ON
under this option, set selection to 'Require a password'

In Authentication section set a user name to :
copied the generated Password to remote machine

using 'VNC Viewer 6.21.920 (r45849) x64 (Oct 14 2021 14:43:07)' client on Mac OS Monterey Version 12.6

Shows an authentication dialog box, I enter the password I copied from the VIM4 machines Remote Desktop Authentication section (VNC does not use the username, just password)

On the client, the VNC client program just hangs showing 'Connecting to'
Never goes past this window. On VIM4 desktop, in upper right corner, the yellow 'Sharing' icon has appeared next to the WiFi icon. If you click on the 'Sharing' icon, the drop down says 'Screen is Being Shared'. But nothing on client side.

If you press the 'Stop' button on the client VNC window, the client stops trying to connect, HOWEVER, on the VIM4, the yellow 'Sharing' icon is still there. You can go in and 'Turn Off' sharing under the dropdown described above.

using 'Microsoft Remote Desktop Version 10.7.9 (2011)

Remote Desktop just shows a black window on client machine, on VIM4 while RDP session is open, shows the 'sharing icon' on upper right corner of VIM4 desktop. When you exit the black screen on the client, the sharing icon goes away on the VIM4

If I logout of the VIM4 machine and try to attach, neither work, VNC shows an immediate message of 'The connection was refused by the computer'

Above steps work fine on a:
MeLE Fanless Mini PC Quieter3Q Celeron N5105 8GB 256GB with Gigabit Ethernet WiFi 6 PXE Dual HDMI 4K Unlock BIOS

Tried removing the password on the login keyring, this had no effect:

sudo apt install seahorse
removed pw from login keyring

Hello @deepvim

Current image using wayland by default, I’m not sure whether VNC can work on it or not.

Have you checked the VNC on the Ubuntu 22.04 with wayland can work well?

I’m not sure if its an option for you, but I am using xrdp for remote desktop to my vim4 with no issue. Of note, I can’t have the session logged in locally on the vim, and the remote session simultaneously.

On your ubuntu, there is no way to select the NOT wayland option. I tried all the login options and the edit of sudo vi /etc/gdm3/custom.conf to disable wayland.

If you try to login to VIM4 with wayland off, you canNOT.

On the MeLe Intel SBC with stock x64 Ubuntu 22.04.1 LTS both VNC and RDP work under Wayland AND you can login with Wayland OFF and again both VNC and RDP work.

I realize x64 and ARM images are different animals, but the fact is the stock Ubuntu 22.04 on x64 works and your ARM image does not.

Hi @hojordsh , Thank you for the idea, I might try that route to just give me something. Can you share your install steps?

It is frustrating to have to do a side route, as Ubuntu 22 has Remote Desktop ‘built in’ as part of its Sharing option.


@deepvim sure, I just did:

on vim4
#install xrdp
sudo apt install xrdp -y

#enable xrdp on boot and start now
sudo systemctl enable --now xrdp

#open Firewall just add your network/cidr below
sudo ufw allow from < enter your local network/cidr> to any port 3389 proto tcp

#if you want to change any default settings you can do so in /etc/xrdp/xrdp.ini

on remote system:
on windows I use mremoteNG or just the windows rdp to access. I’m sure mac has an equivalent

That’s all you need to do I’m pretty sure.

1 Like

Yes, current VIM4 image only support Wayland.

Why have such limitations? Because only with Wayland can use the hardware accelerated desktop.

Gotta love technology… I suffered through Ubuntu not being able to use the NVIDA display drivers, the symptoms were exactly this, you tried to use the hardware accelerated drivers and Ubuntu would barf at the login and just return to login prompt.

Now it is the exact opposite, you try to use a non-accelerated driver and you cannot login …

Progress!!! :slight_smile:

Hi @hojordsh Thank you for the steps, I will give it a try. I use the Microsoft provided Remote Desktop app for Mac OS. It is a bit old, shows a 2011 date for it last update (version 10.7.9) , however a 2022 copyright. All that said, it still runs on a Intel MacOS 12.6 Monterey machine fine.

I tried using VNC and RDP and couldn’t get them working either. All I got was a black screen so I tried disabling Wayland and it borked the system until I backed out the change.

I gave up with the built in desktop sharing feature and installed xrdp but can only log in occasionally and never if a local user is already logged in. Strange that @hojordsh seems able to do so.

I also tried installing different versions of VNC following various tutorials but couldn’t get any of them to work reliably.

Just to be clear,
I can’t rdp if the session is open by another user (or myself locally). I can see in the logs that the session is used and cant be forwarded.

Im pretty sure its /var/log/xrdp it you tail -f that file, and try to rdp you should see what is failing

my bad - looks like I need new glasses because that is exactly what you said, I just didn’t read it right!

Interesting that it seems to be the other way round with VNC on Ubuntu. You can only connect remotely when a local log in is active.

I’ve been trying to get this working for some time without success and found this: but it didn’t help.

So it seems to me that the problem with built-in Wayland desktop sharing could be linked to the problems some people are experiencing with pipewire as both Wayland and pipewire definitely seem to be involved as this: shows.

I realise that both of these are taking about systems other than the khadas but I would have though that some of what they are discussing might apply here.