VIM4 won't power on after trying to install OS

I tried to manually install Arch Linux using the “Manual Installation Example” here. I enabled network access, used ssh to access the prompt in oowow and executed the instructions one by one. When I executed

cat <<-END > system/boot/extlinux/extlinux.conf
label ArchLinux
kernel /boot/Image.gz
initrd /boot/initramfs-linux.img
fdtdir /boot/dtbs
append root=LABEL=ROOT rw quiet

it gave me a ncurses prompt asking me if I wanted to reboot. The wording of this prompt was

┌─────────────────Shutdown system────────────────────┐
│          To boot into your new system!             │  
│             press Reboot or Poweroff               │
│ - -------------------------------------------- -   │  
│ please eject SD card before for reboot from emmc   │  
│       < Reboot >    <Poweroff>    <  Back  >       │  

I didn’t see any harm in doing so, but after I selected reboot my VIM4 will not boot anymore. The status LEDs also do not light up. Unplugging and replugging the USB-C power cable also does not help. Pressing the reset, power, and function buttons does nothing. When plugging in the power cable it uses <1W of power.

Setup Details:

  • Power Brick: The one recommended by Khadas
  • Extensions: M2X Board, M.2 SSD (Issue persists after removing both the SSD and the M2X board)
    • It did boot with the M2X board before, it just stoped booting after executing the above instructions

Did I brick my VIM4? Can I fix it?

@Surferlul Hello,

Sorry to hear your board isn’t turning on, Have you tried putting it back into upgrade mode and force oowow ?

i,e long press function key, short press reset and release the function key shortly after.

Hey thank you for the reply,

Sadly this does not help… When I do this (holding the function key up to 10s, short-pressing the reset key, and releasing the function key shortly after) I get no indicator light, and the fan does not spin up.

Have you tried connecting it to your computer and triple clicking the function button to enter the tst upgrade mode ?

Bricking these devices is very hard given the fact that it should still be re-flashable from the amlogic usb burning utilities.

I used the spi upgrade sd card image and booted from an sd card, which fixed my oowow.

Thanks for the help ^^

1 Like