VIM4 Ubuntu 22.04 Linux 5.4 V1.4-221229 Release

Here we release the new version of Ubuntu 22.04 V1.4-221229 for VIM4.

Change logs:

  • U-Boot

    • Bug fixup
  • Linux

    • Upgrade GPU driver to version r37p0
    • Fix pipewire 100% cpu load issue
    • Enable more kernel modules
    • Add HDMI vesa modes
  • Ubuntu

    • Add Vulkan support
    • Add jpeg gstreamer encoder plugin
    • Add h264/h265 gstreamer encoder plugin
    • Fix pipewire 100% cpu issue

Known Issues:

  • No HDMI hotplug
  • No audio of HDMI IN


  • Fix HDMI hotplug issue
  • Fix HDMI IN audio issue
  • Add more HDMI resolutions

Installation Guide

Install via OOWOW

If you want to do a full clean installation, you can use OOWOW to install the image online.

Upgrade from previous release

If you don’t want to reinstall the system, you can also use the simple commands below to upgrade your system to leatest version.

$ sudo apt update
$ sudo apt full-upgrade
$ sync
$ sudo reboot

Note: For OTA upgrade, current image must be previous release V1.1-220721 or newer release.

By the way

Ths images are built using Fenix scripts, you can use it to build your own image!

Have fun!


Awesome! Does this release happen to provide the ability for additional display resolutions…2560x1440 for example?

Still working in progress, already added some vesa modes, but still have issues for DRM.

I performed the update/upgrade mentioned above, and now my desktop is a total mess.

Here’s a picture of the desktop.

I tried to reinstall gnome without luck.
Things don’t start going sideways until the desktop loads.
If I rdp/xrdp into the desktop, everything looks normal.

Hello @NullOrEmpty

What’s the resolution of your screen? Does it works before the update ?

It worked the day before updating.
3840x1080, that’s the max it will go.

i switched to remoting into the desktop, but it would be nice to get back to working directly on the vim4.

Hello @NullOrEmpty

Could you try to upgrade the kernel and check again?

sudo apt update
sudo apt full-upgrade 
sudo reboot

That fixed the display issue! thank you for fixing it

Below is the output from the upgrade.

sudo apt full-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
# News about significant security updates, features and services will
# appear here to raise awareness and perhaps tease /r/Linux ;)
# Use 'pro config set apt_news=false' to hide this and future APT news.
The following packages have been kept back:
  grub-common grub2-common libnautilus-extension1a nautilus nautilus-data
  python3-update-manager update-manager update-manager-core
The following packages will be upgraded:
  gnome-remote-desktop linux-dtb-amlogic-5.4 linux-firmware
  linux-headers-amlogic-5.4 linux-image-amlogic-5.4
5 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 269 MB of archives.
After this operation, 69.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 jammy-updates/main arm64 gnome-remote-desktop arm64 42.7-0ubuntu1 [123 kB]
Get:2 jammy/main arm64 linux-dtb-amlogic-5.4 arm64 1.4.2 [40.4 kB]
Get:3 jammy/main arm64 linux-headers-amlogic-5.4 arm64 1.4.2 [11.4 MB]
Get:4 jammy-updates/main arm64 linux-firmware all 20220329.git681281e4-0ubuntu3.9 [240 MB]
Get:5 jammy/main arm64 linux-image-amlogic-5.4 arm64 1.4.2 [17.3 MB]
Fetched 269 MB in 23s (11.7 MB/s)                                              
(Reading database ... 217449 files and directories currently installed.)
Preparing to unpack .../gnome-remote-desktop_42.7-0ubuntu1_arm64.deb ...
Unpacking gnome-remote-desktop (42.7-0ubuntu1) over (42.4-0ubuntu1) ...
Preparing to unpack .../linux-dtb-amlogic-5.4_1.4.2_arm64.deb ...
Unpacking linux-dtb-amlogic-5.4 (1.4.2) over (1.4) ...
Preparing to unpack .../linux-firmware_20220329.git681281e4-0ubuntu3.9_all.deb .
Unpacking linux-firmware (20220329.git681281e4-0ubuntu3.9) over (20220329.git681
281e4-0ubuntu3.7) ...
Replaced by files in installed package linux-board-package-jammy-vim4 (1.4) ...
Preparing to unpack .../linux-headers-amlogic-5.4_1.4.2_arm64.deb ...
Unpacking linux-headers-amlogic-5.4 (1.4.2) over (1.4) ...
Preparing to unpack .../linux-image-amlogic-5.4_1.4.2_arm64.deb ...
Unpacking linux-image-amlogic-5.4 (1.4.2) over (1.4) ...
Setting up linux-image-amlogic-5.4 (1.4.2) ...
update-initramfs: Generating /boot/initrd.img-5.4.180
/etc/initramfs-tools/scripts/local-top/ 41: cannot create /sys/cl
ass/graphics/fb0/blank: Directory nonexistent
/etc/initramfs-tools/scripts/local-top/ 44: cannot create /sys/cl
ass/graphics/fb1/blank: Directory nonexistent
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.15.0-1007-nvidia-64k
Found initrd image: /boot/initrd.img-5.15.0-1007-nvidia-64k
Found linux image: /boot/vmlinuz-5.4.180
Found initrd image: /boot/initrd.img-5.4.180
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Setting up linux-firmware (20220329.git681281e4-0ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.15.0-1007-nvidia-64k
/etc/initramfs-tools/scripts/local-top/ 41: cannot create /sys/class/graphics/fb0/blank: Directory nonexistent
/etc/initramfs-tools/scripts/local-top/ 44: cannot create /sys/class/graphics/fb1/blank: Directory nonexistent.........PProgress: [ 57%Progress: [ 57%] [#####
update-initramfs: Generating /boot/initrd.img-5.4.180
/etc/initramfs-tools/scripts/local-top/ 41: cannot create /sys/class/graphics/fb0/blank: Directory nonexistent
/etc/initramfs-tools/scripts/local-top/ 44: cannot create /sys/class/graphics/fb1/blank: Directory nonexistent
Setting up linux-headers-amlogic-5.4 (1.4.2) ...
Compiling headers - please wait ...
Setting up gnome-remote-desktop (42.7-0ubuntu1) ...
Setting up linux-dtb-amlogic-5.4 (1.4.2) ...
Processing triggers for libglib2.0-0:arm64 (2.72.4-0ubuntu1) ...

1 Like

Hi @winslowb @NullOrEmpty

I have added new resolutions support, e.g. 2560x1440, 3840x1080

Could you guys help me to check whether resolution 2560x1440 and 3840x1080 works on your side? Or other resolutions doesn’t work for you ?

Please follow the stesp below to upgrade the kernel:

cd /tmp
sudo dpkg -i linux-dtb-amlogic-5.4_1.4.2_arm64.deb linux-image-amlogic-5.4_1.4.2_arm64.deb
sudo reboot

I tried the update you outlined, and the display went crazy again, exactly like what I posted above.

Okay, please follow the steps below to go back to previous version:

sudo dpkg -i linux-dtb-amlogic-5.4_1.4.2_arm64.deb linux-image-amlogic-5.4_1.4.2_arm64.deb
sudo reboot

I need to check what’s going wrong on my side, thanks for your help.

1 Like

awesome…i’ll install tomorrow and follow-up here! thanks for taking the time to work on this. i appreciate it.

excellent @numbqq … it worked! this was a big deal for me and i really appreciate it. thanks again for working on this!!!

1 Like

hey @numbqq

Did you by any chance add the 1024x600 resolution ?

Thanks !

Worked great on my Samsung QN75Q6FNA TV (HDMI connect) until the December update.
I tried your steps from the repos, no help.

Yes, we will.

What’s the resolution of you screen ?

Successfully running 1920x1080 (16:9) @120Hz running Wayland on all thru Oct OOWow desktop.release. Upgrades and December desktop release cause the display to wrap and overlay on itself. Adding the repos did not help after upgrade or December OOWow load.

Thanks for your quick response.

Hello again
I managed to get into Display settings after full upgrade and adding your repo to the wrapped display and then went into wayland Settings->Displays->selected 3840x2160(16x9)@60Hz and set scale 200% and I have success, viewing on 75" Samsung TV again…
Thank You for the help.