Vim4 gpio with wiringpi

hello im having difficulty using the gpio with wiringpi on vim4.
its giving ,

Oops: Unable to determine board revision from /proc/device-tree/system/linux,revision
or from /proc/cpuinfo
→ No “Revision” line
→ You’d best google the error to find out why.

have tried reinstalling from many sources but seems the vim4 processor info is not recognizing.
any help!

Its a bit frustrating as i read the docs before getting the vim4 and it seemed its easy to access the gpio with wiringpi. I have tried other libraries such as gpiozero but without suprise its not working. I wouldnt mind using c or python to access gpio. Would appreciate any help as i have plans to do some robotic projects with this SBC. Thanks in advance

@hannu I will fix it today.

1 Like

Thanks i look forward to a fix…:slight_smile:

@Frank I was just wondering once the issue is fixed, would i need to reinstall ubuntu via oowow wizard? Also will you be bringing a fix on working with wiringpi or some other library? I have read some forums on wiringPi and i am getting the impression the author is asking to look for alternatives to wiringPi. Also will I be able to install Raspbian OS on vim4 and get away with using the existing libraries used in the raspberry pi to interact with the GPIOs of vim4. Will the hardware support?


You can download this and install with VIM4.

ok let me try that. thanks

@Frank Hey thanks. That did work .Also if you know any way to reconfigure the rest of the pins to simple IO pins that would be helpful. Right now i am just able to write to the few IN pins.

@hannu This needs to wait for the overlay function support, which is in our future plan, but you need to wait for a while, or modify the kernel source code yourself, and then recompile the firmware

I am looking forward to this plan. :pray:

@Frank ok. Another issue I am having with using wiringpi python. I am able to run c scripts to access the gpio but with python I’m getting the same error. I guess i can work with c but i prefer to work with python. In the python script once the code hits the wiringPiSetup() function it throws the same error. Probably there is a problem with python wiringpi getting access to the c program

@hannu I will check it next week.

1 Like


Try with my new package.

khadas@khadas $ wget
khadas@khadas $ sudo dpkg -i python3-wiringpi_3.13-1_arm64.deb
1 Like

@Frank I am having trouble installing the package as my ubuntu version is running python10. Any possibility you can adjust the package to this version of python. Thanks. By the way i have installed python3.8 addition to my system but seems when installing the package it looks for the system installed version of python in this case is 10. I have made python3.8 as default also but with no hope.

@hannu You can build by yourself.

It should work with python3.10