Vim4 boots to a black screen

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas official images

Please describe your issue below:

I installed ubuntu 22.04 on vim4 as follows.

And I rebooted according to the message. After that
The Khadas logo appears and a black screen is displayed.
I need help.
Thank you.

if your OS system non boot-able , lets try start oowow with FUNCTION + RESET, which can help to solve problem

possible solution

  • try to check whats wrong with current OS - menu → shell → check fs , os logs, etc … (rescue procedure need some linux skills)
  • try reinstall
  • try install other images

How long are you waiting for it to boot?

Do you have a TTL interface connected to linux UART port, this can monitor what is going on during boot.

Thank you for your reply.
I tried the following.
Unfortunately, the same thing is happening.

  • The only shell I could access was the shell in OOWOW. Several methods were attempted, but did not work.
  • I reinstalled it, but the vim4 did not boot.
  • Tried installing all other images, but did not boot.

Thank you for your replay
I waited for about two hours. But it didn’t boot
I will try to find the way you mentioned.
Thank you!

I would like to suggest you to install an image manually.

  1. Download this file :
  2. Decompress 7z file, then check the extracted file size. it should be 1,798,461,936 bytes.
  3. Update via USB - follow this guide :Install OS into eMMC | Khadas Documentation

Trank you… but this way also did not boot.
It’s so sad…

rescue system via linux shell need some basic linux skills
some examples :wink:

blkid $(mmc_disk)
fsck.ext4  $(mmc_disk)p1
fsck.ext4  $(mmc_disk)p2

Thank you, I tried the method you mentioned, but it just didn’t work when I got the following message:
“the superblock could not be read or dose not descritbe a valid ‘…’ filesystem”

And the other way around, I looked up Linux skills on Google, and it didn’t work.

Thank you.
I tried the method on the page below, but I couldn’t find a way to enter /boot.

  1. goto oowow shell
  2. mkdir boot
  3. mount $(mmc_disk)p1 boot
  4. ls -l1 boot

I tried all the disks along the two pages below, but there was no output.

  1. my recommendation rescue shell is for advanced user - its mean need have some *nix skills - if u dont know how - please read some mans … easy to get tons of them in internet
  2. please read my prev topics

its not solution its just examples

blkid $(mmc_disk)
fsck.ext4  $(mmc_disk)p1
fsck.ext4  $(mmc_disk)p2

Do you have a ttl-USB converter connected to the VIM board and using a different machine with minicom?

I connected it to a different monitor and it worked. I think it’s because I used a monitor with an unsupported resolution. However, the oowow screen or logo screen came out, so I thought it was a monitor with resolution supported by vim4. Be careful of the others.

yes oowow force setup to fullHD, i have try to imrrove it

BTW: whats was your supported resolution?