VIM4 Android and SSDs

Which version of system do you use? Khadas official images, self built images, or others?

Khadas Official Android Image (Latest version as of time of writhing)

Please describe your issue below:

I am using VIM4 with the new NVMe module. I am trying to use Samsung SSD 980 PRO 2TB, however in the storage menu I see it listed under portable storage with a label “Unsupported”. The disk is brand new and hasn’t been formatted in any way yet. I was hoping to do that through Android.

Post a console log of your issue below:

I don’t have a console log to share.

I have checked that the Samsung hard drive is loaded normally. You can try to format it and insert it into VIM4. Can you provide serial port printing and the like?

Thank you for the quick response!
I removed the SSD, connected it to a PC and then initialized it and formatted it.
I confirm that now it works as expected and everything looks fine.

As mentioned earlier the disk was never used before and I was hoping to have it formatted through Android. The reason for that is that I didn’t had a free adapter at that time. But the important thing is that it all works now.

Thank you so much for the quick response! :slight_smile: