VIM4 and OOWOW custom non-standard display resolution problem

We are using VIM4 board with Ubuntu 22 (tried both server and desktop) that runs Wayland as replacement of x11.
We are using a custom display for advertisements and its resolution is 3840x720@60hz

When loading VIM4 OOWOW loader it sets defaults resolution to 1080p and when Ubuntu Server loads it also sets resolution to 1920x1080. When Ubuntu 22 desktop loads I can set 3840x2160 and 1920x1080, but no way to set 3840x720.

I tried so far options that didn’t work:

  1. xrendr → will not work as images use Wayland and not x11
  2. boot_user_args=video=HDMI-A-1:3840x720@60, adds resolution to the list, but when switching to it freezes the system with no display output and requires rebooting.

Also when just starting OOWOW loader via Func+Reset, it loads 1080p and there is not way to adjust the resolution.

The display was tested with windows Intel tools to force desired resolution and everting worked and display detected proper resolution.

Please help me how/where to adjust the proper resolution and force the system to output it.

Thank you.

The special resolution 3840x720 maybe not supported at this moment. As we don’t have such screen on our side so we need your help to provide some information of the screen.

When you attache the screen and bootup the system then login via ssh and provide the information below to us.

$ edid-decode < /sys/class/drm/card0-HDMI-A-1/edid > edid.txt
$ dmesg > kernel.txt

Please provide the files edid.txt and kernel.txt to us.

Thank you. I did the dump and attaching confirmation and files.

  1. The display: DV480FBM-N01-D830 and I am attaching full spec of the display below.

    • Display outputs 51 pin V-BY-ONE cable
    • Ideally I would love to connect this to VIM4 directly to it’s vbyone port, but it’s mismatching pins I assume we need an adopter that have not yet been implemented on your end.
  2. The display is plugged into a V-BY-ONE controller board that has HDMI interface

    • I have 2 different boards that act differently, if possible, please help with both of them
      a. The first controller board is 4K AD board BH-4K02-E01 (attaching specification and edid+kernal dump)
      b. The second controller board is MH08B 3840X2160 QFHD V-BY-ONE LCD controller board (I don’t have specs, just adding edid+kernal)

Thank you and please do let me know how I can help. Ideally I need to support 3840x720 at 30 and 60Hz and if it’s not a lot of hustle 1920x360 also at 30 and 60hz.

Also if you have any info on how to connect 51pin V-BY-ONE directly into VIM4 through your adopter, this would save a lot of time for us.

I am not sure if there is a way to select custom resolution for OOWOW itself as well as uboot/linux, but that would be great! I know this is not way as you need a custom image or a menu to set this up.

  1. a BH-4K02-E01 to HDMI
  2. b MH08B to HDMI

Please don’t hesitate to ask any questions.

Hey guys, I know you are busy, but any updates on this?