VIM3L (v14) - no image display on Oowow, Krescue and others

Just got my new Khadas VIM3L (v14) and so far this is the worst single board computer experience I’ve ever had.
Krescue and Oowow run at a very weird display refresh rate that neither of my NEC and EIZO monitors can handle, so every time I need to flash an image to the emmc I have to connect my little drone monitor which is the only monitor that can handle that weird resolution/refresh rate or I use an ssh connection.
My board came with Android installed on eMMC, but when I try to flash another image it just won’t boot.
So far I’ve tried Ubuntu server, Volumio and Armbian and nothing works.
Yes, I am downloading VIM3L specific images. I have tried krecue and Oowow but with both I have the same effect.
What’s going on?! Please help.

I found that I was actually running Linux but due to a strange refresh rate I didn’t get any image on my main monitor, however Volumio (both versions) stuck in a reset loop.

The interesting to mention is that Android was able to display proper image.

Can you take a photo of the screen you get when it boots oowow from SD card?

What are you using for an adapter from the HDMI to the DVI of your monitor?

Do you have HDMI on the monitor?

1 Like

I use a regular HDMI to DVI adapter (no electronics inside). This setup works fine with Raspberry Pi, Orange Pi and Odroid, also when I run VIM3L with Android I get the image. My monitors are NEC MultiSync PA241W and EIZO ColorEdge CG241W. My little drone minitor that always works is the Feelworld PVR-732.

  1. I don’t have HDMI ports on my monitor. I only have DVI and DisplayPort ports.

I’ve read that many people have trouble running Krecue and Oowow from an SD card.
Maybe these people are actually booting from the card properly, but they don’t even know it, because they don’t have an image on the monitor, just like in my case.

I managed to install Armbian to eMMC memory and the image on my monitor displays correctly.
It turns out that the display image problem only affects the system images available on

What about Volumio? Why is it stuck in a reset loop. It seems that the provided images for VIM3L are broken.

1 Like

Glad you are heading the positive direction with this. I had plenty of trouble using adapters, many of them are junk and do not work. Now, you know the hardware is fine.

I’ve been using my adapters for years without any problems, besides that the image from VIM3L is displayed correctly from Android and Armbian.
You can see that the problem is the configuration of the refresh rate for the display for Ubuntu(all), Oowow and Krescue.