VIM3L unable to reinstall to EMMC


I’ve been trying to make some tests on my VIM3L board with Kodi, since I had one video which had choppy playback on CoreELEC, so I wanted to make tests and compare CoreELEC, Ubuntu with Kodi and Android with Kodi.

After flashing the Android via Krescue SD Card, image VIM3L-Android-TV-SC_USER-v3.0-20201125, I am now unable to boot from Krescue SDcard to reflash the emmc.

1st tried with the, the zip was not in the image, so after a while I found some topic on othe SBC, that you just need an empty (was weird, but tried), but it didn’t help

2nd tried to reflash the SD card with Krescue, tried different SDcard, reader, and program to flash it, neither was successful. When the SD Card is in the reader, the boot logo of Andriod TV powered by SuperCeleron is distorted.

3rd tried the Keys boot to Krescue, tried the Mregister to boot from SD card, neither helped

4th tried the Burning tools on Ubuntu and Windows. seemed most promising, as I’ve seen the Amlogic device in those OSes, well but in the end both failed. Ubuntu just showed Unpacking image [KO]. Windows showed more information, but in chinese. Error [0x10303004].

Can you please help me with next suggestions to re-flash my board away from Android?

What works the best for us is Pi Imager on X86 or ARM 64 box (Ubuntu OS). Burn krescue on the SD using that.

When you get it to boot krescue do a full erase of emmc before reinstalling. Also do a full erase of SD card before burning Krescue.

1 Like

Hi foxsquirrel,

The process I refer to as burning is flashing the emmc directly via PC to emmc (see Install OS into eMMC | Khadas Documentation ).

The flashing of SD card was done (as per my 2nd point) multiple times via multiple tools(Rufus, Etcher[Windows], Etcher[Ubuntu], even the RPi Imager) using multiple SD cards (3). I have problem with the VIM3L to boot from SD card. So I would say it is not the SD card flashing tool, od SD Cards I’ve used faulty.

Pi imager has been doing a good job for us. Might be the card??

Do you have a TTL to USB adapter so you can see the actual boot sequence on Linux port?

If you can do a screen shot where it hangs up that would help to find the problem.

Tried 3 different cards with integrity checks, neither successfully booting to Krescue. Neither with flashing using the Pi Imager was successful. Also the first few times I used the same SD Card I have used successfully in the past several times with the same Krescue without re-flashing(same I burned this Android).

Unfortunately I don’t have TTL to USB adapter, can I wire it via GPIO pins on different VIM3, which has Ubuntu, or a Raspberry Pi?

What about the burning tool and the error [0x10303004]? I can recreate the logs and post them here, but they exceed the maximum character limit of the forums post length.

What about the, is there a place to download it somewhere? Didn’t find it on the Khadas dl site, and it is mentioned on the forum few times.

I will post the screenshot in the next post. Basically there are three scenarios:

  1. No SD Card inserted, the boot goes to the emmc and Android boots up. No problem
  2. SD Card inserted, pressing the F-key 3 times in 2 seconds, LED blinks blue, then changes to white and the VIM3L is stuck in the booting loop, never to get to the Android, just distorted image of the Android splash screen shows up and after few seconds reboots, and again …
  3. Using the Khadas burning tool, and the VIM3L connected to PC via USB-C cable, pressing the F-key 3 times in 2 seconds, the LED blinks blue, then LED turns off, and the PC recognizes the board being connected. Burning tool gives error [0x10303004].

In the past when I was installing to the emmc the VIM3L detected SD card and prioritized the boot from SD card so I could use the Krescue to change the OS. Now with the Android installed, this mechanic does not seem to function, or has some limitations with the Android OS.

Normal boot without SD card inserted:

Distorted image boot with SD card inserted. Just looping restart with these two screens:

Don’t know what did I do differently, but in the end the Burning tool did the job > Install OS into eMMC | Khadas Documentation

What I want to emphasize for the future is not to use virtual machines for this tool, as in one step it disconnects for the USB for a split second and the VM can’t cope with it.