Vim3L noob questions

Тогда всё просто! USB Burning Tool умеете пользоваться?

Do you mean to record the image on the SD card (yes I can)?
or use a UART USB cable to connect VIM3L to PC?

Вам нужно прошить последнюю версию, лучше всего стоковый андройд как раз через USB Burning Tool по кабелю, и потом я думаю не должно быть проблем с загрузкой krescue

1 Like

maybe … but I thought, on the device itself, there should be some kind of key combination so that you can clear the memory without additional manipulations (there is USB Burning tool for Windows OS and it’s not convenient for me… i use linux).

Well then, Hyphop in the post you quoted just gave you an algorithm of actions :slightly_smiling_face:
as a last resort, write to sd, and from it install

unfortunately algorithm cannot be executed using the console and enter commands in the same OS (Superceleron`s ATV ROM) that you need to remove from EMMC (therefore, I am sitting right now and thinking how to do it step by step. As I understand it, I need to connect VIM3L via a cable to a PC and enter these commands from under the PC console) :slight_smile:

no, by the means of the Internet, drive teams into the terminal

Unfortunately, I do not understand this (do you mean access by ssh?), therefore, and that is why I ask for support (step-by-step instructions).

:rofl: I already tried it friend :slight_smile:, the error “there is no access EMMC memory” (if it were all so simple, I would not ask a question :slight_smile:).

install Windows, USB Burning Tool, and don’t bother yourself :wink:

1 Like

send me link to your firmware which was flashed and block bootup from sd - i can check it

if system was installed from krescue - i can get warranty u can boot krescue from sd next time without problem

but old android firmwars still possible to boot read this insructions

https://dl.khadas.com/Firmware/Krescue/dump/README-rescue-boot.txt

VIM3 VIM3L

Android default firmware

  • unplug usb cable
  • insert SD card with Krescue
  • press and hold POWER_KEY
  • plug usb cable and wait LED blinking after u can unpress POWER_KEY
  • ok Krescye system bootup from SD

VIM3 VIM3L usb otg NOTE

same as previous , but usb plug in host machine

need plug usb cable in two steps on host side

  • power without data pin connection - just slowly plug about 1/3 length usb header - before powerup
  • wait blinking leds and plug usb cable for full length for activate data pins
  1. if u have UART u can goto to uboot command line and just write store init 3 && reset
1 Like

This is VIM3L.Android.TV_FINAL-v1.0-20191023.SC.emmc.kresq

Yes, I installed this VIM3L.Android.TV_FINAL-v1.0-20191023.SC.emmc.kresq using your boot ROM (SD card with Krescue). It is pointless to fix it because new user will install new build # 2 VIM3L.Android.TV.v2.0-20200120.SC.emmc.kresq (https://dl.khadas.com/Firmware/Krescue/images/VIM3L.Android.TV.v2.0-20200120.SC.emmc.kresq).

I do not understand what it means “need plug usb cable in two steps on host side” and “plug usb cable and wait LED blinking after u can unpress POWER_KEY”?!? What kind of USB cable mean (some special UART USB cable or just a VIM3L device power cable? need to connect and reflash to a PC or what? If it means that I simply apply power to the device via the USB cable without connecting to another PC, then I cannot start the boot Krescue ROM. All the time, regardless of the key combinations, I see the Superceleron boot logo and his ROM is further loaded without options. And I trying to install over the network, as in your video :slight_smile: and when I try to write any other image to the EMMC memory VIM3L… an error occurs. Usually a similar problem on a my PC I decide having root privileges… but here I don’t understand how to do this from an ordinary user who does not have permission to write the image to the EMMC memory VIM3L)?

I realized that I need to look for a special cable (which cable is needed? 5 pins?) :), then connect it to another computer (and there it will already be authorized without a password as a root and then only manage to reflash) for a flashing, but I was hoping that there was a simpler option.

When you have tried using a PC and the USB Burning Tool, you get error when trying to flash the firmware?
If so, how far does the progress get before the error?
If it gets past 17-18% before the error, try again and while the update is progressing, around 15%, disconnect the VIM3L from the PC. That should erase the eMMC.

Forgive me if I have repeated something. I read through this thread but I just skimmed it, and may have missed it.
Good luck.

no, he has a different scenario :slightly_smiling_face:

OK. I should have read deeper.:blush: :smile:

i just check this firmware now -> VIM3L.Android.TV_FINAL-v1.0-20191023.SC.emmc.kresq

its works without problem and Krescue can start from sd without any manipulation

  1. if uboot env was changed - its possible to block boot up from sd
  2. just try another SD card may its problem ()

I do not understand what it means “need plug usb cable in two steps on host side” and “plug usb cable and wait LED blinking after u can unpress POWER_KEY”?!?

yes its same usb power cable! if u press longer POWER_KEY uboot goto update mode but if cable connected to pc uboot goto burn mode

i have check it too same works fine !!!

1 Like

100% method for clear emmc from android under android shell

goto android shell (need root) just one line - magic bullet for your diabolic android

su; b=/dev/block/mmcblk0; for o in ${b}boot0 ${b}boot1 $b; do dd if=/dev/zero count=666 of=$o; done

many different ways for clean emmc

2 Likes