VIM3L- New M2X SSD setup

Hi, just a couple of newbie questions.
I have purchased the new M2X board alongside with the older one.
Also I have bought a 256gb NVME ssd

I have connected the ssd to both m2x boards using Android and Linux with the following results
Android (latest version) doesn’t see the drive at all
only getting a message
This device does not support this spcc m.2 pcie ssd pcie drive. Tap to setup in a supported format.
When I tap on the message nothing happens.

When using ubuntu I am able to see the drive in GParted however when trying to create a partition it asks to create a partition table first. When I try to create a partition table it throws an error “Input/Output error when trying to write on dev/nvme0n1”

I assume that the drive should be OK since Gparted displays it’s total volume correctly.

What can I do to fix this?

Hello, As you can see the drive, I assume you have already set the USB3/PCIe switch to PCIe.
I do not believe Android can do anything with it until the drive is formatted.
Not sure about Linux, I have no VIM3L to test on. That being said, no issues with either OS on my VIM3 with either M2X or New M2X boards. I am using a cheapo Patriot NVMe drive. With NVMe, drive compatibility is not always assured, even on X86 platforms.
Just for grins, have you tried sudo gparted?

@fender90 we’ve discussed about a Supported SSDs a while ago, you may check it out, I suggest seeing if you can use any of those SSD’s that are supported :slightly_smiling_face:

P.S I found on the website of silicon- power that “according to them”,

links to their product page, and official document

Stay safe & Good day!

No I haven’t tried sudo gparted. will try today.
I would also try to connect the ssd to my laptop using a usb3 adapter but unfortunately I do not have one yet.

I’m slowly starting to get frustrated because of VIM3L,
SSD support is poor
Android is buggy, poor usb touchscreen support, problems with the resolution on ts050 display, video gets inverted and more…
Linux works extremely slow.

I guess I will have to put it in a drawer to wait for better times.