VIM3L is almost bricked (SPI uboot damage)

Hi there!

My VIM3L was configured with latest Armbian and SPI_Flash uboot. Every was fine before I’ve accidentally damaged SPI flash content by writing to the wrong SPI dev… Now device doesn’t boot and not allow me to enter any recovery mode. TST, MASKROM, etc. don’t work anymore, connected PC doesn’t feel any USB presence. Serial debugging just show a short word “SM1:” after power on and nothing more ((. What can I try to recover my VIM? Or it’s die completely?

Thanx a lot!

does triple clicking the middle button still not make it recognizable to your PC?

check this:

TST Mode doesn’t work as i wrote. When i triple click middle button i see triple flash from blue led and nothing else (no PC connection, no reaction in uart console). I khow how to use this mode and i used it many times but not now.

perhaps it is really is bricked, consult @Frank

Finally i’ve brought my vim back to life! I’ve tried M-Register method and it worked!

Thanks for help anyway.

1 Like