VIM3L IR and CoreELEC 19.X

Hello all!

I’m currently remaining on CoreELEC 9.2.7 for one reason: out-of-the-box IR remote functionality. No IR is a deal-breaker.

My machine is a VIM3L and the IR works fine on any CoreELEC build prior to 19.X.

Are there steps I can take to enable IR controls on the unit using CoreELEC 19? I’m familiar with using SSH if that’s required to add or delete files.

Thanks for the help!

Hello And welcome to the forum,

Have you tried asking it on CoreElec forum? You will get faster reply on there.

Try it on their forum.

Good luck.

u can install CoreELEC 9.2.5 and 9.2-Matrix from Krescue (IR works out of box ) dl.khadas.com - Index of /Firmware/Krescue/images/

Good luck

They do work great but I would like to use the “VIMx.COREELEC.19.2-Matrix_rc2.emmc.kresq” image since it has Kodi 19 in it.

I’ve tried to configure using “remote.force_meson_ir” just as with CoreELEC 9.X but it doesn’t work.

Also ir-keytable gives me the error:

ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
/sys/class/rc/: No such file or directory
No devices found

Are there missing files or steps that I need to take?

Thanks! :pray:

I tried there first but none of their suggestions worked and they told me to come to this forum.

They also said they don’t support Krescue images. :man_shrugging:

Yes that is supported by @hyphop

Really? Hmm. Portisch over there said:

Kresuce images are not supported by CE.

@hyphop would it be possible to compile a Krescue image of CoreELEC 19.X that supports remote controls out-of-the-box like CoreELEC 9.2.X does? That would be wonderful! :bowing_man:

I doubt on that as @hyphop Only maintains image for krescue. What youre asking is to add ir function on coreelec for the device which is part of coreelec team but if its a small change then maybe hyphop can help.

Good luck.

u or any other can ask coreELEC about this ! i just make it for Krescue images all sources there

Good luck

1 Like

Just use this command in ssh if you’re using khadas remote echo "meson-ir * kvim.toml" > /storage/.config/rc_maps.cfg and the reboot

Thanks for the hint! :star_struck:

I’m actually using a Chunghop L336 remote. Do I need to upload anything from the remote repository to make this work? I’m new at the remote configuration, I’ve never had to do this on any build prior to CE 19.

That’s for the khadas remote. I really don’t know how you couldn’t make the others work after following the guides. Aside the .toml added to the remote’s file name there aren’t big changes in remotes between versions. I have several devices and didn’t have any problems.

It’s so strange. No matter what I do to try to get the remote to work I can’t. I made the .toml file, rc_maps.cfg file, added a remote.force_meson_ir file to the .config folder. Still nothing.

I’m using the Krescue image of CoreELEC 19 RC2.

When I troubleshoot I always get this error in SSH:

ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
/sys/class/rc/: No such file or directory
No devices found

It seems as though the system doesn’t initialize the IR at all. :thinking:

I can confirm that the IR isn’t working when attempting to read keypresses.

This is the SSH shell after a reboot (and a recent restore from the CE 19 Krescue image):

CoreELEC (official): 19.2-Matrix_rc3 (Amlogic-ng.arm)
CoreELEC:~ # ir-keytable
/sys/class/rc/: No such file or directory
No devices found
CoreELEC:~ # systemctl stop kodi
CoreELEC:~ # systemctl stop eventlircd
CoreELEC:~ # ir-keytable
/sys/class/rc/: No such file or directory
No devices found

Are there steps I can take to make it so the ir-keytable device is activated?

I’ve looked at all the guides I can possibly think of and I still get the “No devices found” error.