VIM3L (HTPC kit) CoreELEC Matrix

Hi all

I have VIM3L HTPC Kit running preinstalled CoreELEC 9.2.5 in eMMC.

I wonder how to upgrade CoreELEC, for example, say, tomorrow CoreELEC
team releases official 9.2.6, do I simply put the tar file in
~/.update ?

Reason why I ask is because I want to test CoreELEC team 19 Matrix
Beta 2 (Development Release).

Please find following thread in their forum

If thread cannot be consulted I will cut&paste relevant conversation

Basically CoreELEC team requests their 9.2.5 installed in eMMC from SD
card with ‘ceemmc’ prior to testing Matrix Beta 2. But, to install to
eMMC with ‘ceemmc’ one needs to run Android. I have both tried (1)
VIM3L-Android-Pie_V201113.fixed.raw.img.xz (installed with Krescue)
and (2) VIM3L_Pie_V201113.7z (installed with USB Burning Tool), but:

  • ‘ceemmc’ failed when having Android in eMMC using method (1)
    … CoreELEC team does not support krescue images, so is said.

  • unlike with method (1) CoreELEC does not boot when having Android in
    eMMC using method (2). Maybe that’s because aml-burn-tool does not
    support board VIM3L, and I have used command ‘aml-burn-tool -b VIM3
    -i update.img’ instead. Boot into upgrade mode went to recovery

  • I also considered (3) install VIM3L_Pie_V201113.7z from Burning
    Card, but, I do not find an SD u-boot file present in

So now I wonder which Android to flash to eMMC and which flash method to use
in order to be able to use ‘ceemmc’ to install CoreELEC team 9.2.5
version in eMMC on VIM3L (HTPC Kit).

note that in

a paragraph is dedicated to VIM3L stating one needs dtb.img in eMMC
/flash, but, the day-1 preinstalled Khadas CE software does not have this
file. I simply tried to copy device_trees/sm1_s905d3_khadas_vim3l.dtb
to /flash/dtb.img but such resulted in VIM3L not booting (and I
restored from Krescue).

1 Like

Hi, if given coreelec provides dtb for vim3L, write the official image to sd / usb without any problem and boot into the system.

My opinion about 19 Kodi is not very good, in fact, you will be deprived of everything there, and most likely you will return to the old, working coreelec, however, it will be interesting for me to know your comment.

Khadas VIM3l users
Please be sure you have a file /flash/dtb.img on your current eMMC installation before upgrade to CoreELEC-19-Matrix! Otherwise the device will stop booting and a recovery will be needed!

Open a SSH connection and check it by:

CoreELEC:~ # ls /flash/dtb.img
If the output look like this the system is compatible and can be upgraded to CoreELEC-19-Matrix. If you get a “file not found” please restore your system like with a Android image or a krescue image before upgrade!

1 Like

Thanks for reply, One aspect is: I want to help test Matrix and will sure revert back to Leia for daily usage. To test Matrix I can do so booted from SD. The other aspect is: I want to be prepared, when Matrix is ready for daily usage, for it to be installed in eMMC. The comment about the /flash/dtb.img seems to be about that aspect. But, the Khadas pre-installed CE does not have this file. It has all files in /flash (and they are all equal to the ones in standard CE). In particular there is /flash/device_trees/sm1_s905d3_khadas_vim3l.dtb. If I copy that file to /flash/dtb.img, the VIM3L (HTPC Kit) no longer boots (but I can recover having Krescue and Kodi backup). According to CE forum this is because VIM3L (HTPC Kit) CE installation is different from ‘official’ CE one (and the test I did proves this). I guess the u-boot is probably different. So to run ‘official’ CE in eMMC I am asked to first install Android and then boot ‘official’ CE from SD and then copy it to eMMC using ceeemc. Details are in CE forum link given. In short: ceemmc fails, and, ‘official’ CE does not boot from SD, dependent on flash method (Krescue or USB Burn) and image (I tried Pie_V201113). So now I wonder: maybe I need to flash another Android and/or use another flash method? Basically I start from preinstalled CoreELEC 9.2.5 in eMMC and want to end with official CoreELEC 9.2.5 in eMMC (with the requested /flash/dtb.img). Then I can, later, upgrade to official CoreELEC Matrix. Do you have a VIM3L (HTPC Kit)?

Yes, try to flash official Android on eMMC via UBT and load coreelec on sd / usb, in theory this is the most correct scheme.

Thanks for kind reply.
Thing is, which official Android and how to flash?

  • I tried VIM3L-Android-Pie_V201113.fixed.raw.img.xz with Krescue and it booted Android and I can boot official CE 9.2.5 from SD but ‘ceemmc’ failed (Error dtb magic: !)
  • I tried VIM3L_Pie_V201113.7z using USB Burning Tool from Linux. Note the following
    aml-burn-tool -b VIM3L -i update.img
    ERROR: Unsupported board: [VIM3L]
    so I tried ‘-b VIM3’ and it booted Android but then I cannot boot official CE 9.2.5 from SD (I end up in recovery)
  • I wanted to make a Burning Card for VIM3L but found no SD u-boot files present in

in short, nothing succeeded so far to install official CE 9.2.5 in eMMC

I reverted back to where I came from (preinstalled CE 9.2.5) with Krescue and Kodi restore.

Perhaps I use wrong image(s) or tool(s), perhaps someone can provide me the files that are needed to make a VIM3L Burning Card?

Here are the official images, at the very bottom for vim3L Android.

1 Like


Thanks for kind follow up.

VIM3L_Pie_V201113.7z (md5sum 53d43541157aded6c29d6fe331b078d0) is indeed the image I flashed with USB Burning Tool, but, as said, aml-burn-tool did not like ‘-b VIM3L’ so I used ‘-b VIM3’, and, while Android got flashed correctly in, and, also booted from, eMMC, I could not boot official CE 9.2.5 from SD (I ended up in recovery).

Now I tried making Burning Card for VIM3L (following guide) and used from (as is empty)
I can get the SD card to boot (it contains aml_sdc_burn.ini (from and update.img (from VIM3L_Pie_V201113.7z)) but it ends with:
Cannot autoload with TFTPGET
I also see:
Card did not respond to voltage select!

The problem was the VIM3L_Pie_V201113 image … After I USB Burn the VIM3L_Pie_V200320 image I can ceemmc official CE 9.2.5 from SD to eMMC

This thread is a bit old, but it is the only one that I have found on VIM3L and upgrading CoreELEC. Does anyone know what the status is on using the latest Matrix 19.2 RC3 build on the VIM3L? I can find no confirmation on their forum either.

u can try write it via Krescue

That worked great—thanks! Will I need to do this for future updates, or can I use the official CoreELEC methods?

I recently bought a VIM3L HTPC to use with my new projector.
I noticed the Coreelec 19.2 Matrix has been released yesterday. An RC2 was available on the download site a while ago.
When do you think the final version will be available from Khadas?


tnx for notification ! i will update image tomorrow !


I am still very new will all this.
Would it be possible to update it directly from coreelec?
Will I need to use Krescue and upload the new image myself?

why not try !!???

Menu → CoreElec > Updates > Automatic Updates = manual

  • Update Channel CoreELEC-19
  • Available Versions > …
  • Update to … Now

PS: CoreElec images updated:

Thanks @hyphop

Like I mentioned yesterday, I’m just starting to navigate through coreelec.
What you just described was my expectation. As I read many different threads I wanted to be sure which was would be best in advance.
Now, I just tried the update. Sadly at startup it is now stuck with the message saying

Could not mount LABEL=CE_FLASH

Will use your other post to fix that with krescue now.
Not sure I have another way to go back to coreelec.

Strange update works for me ! make update from rc2 to rc3 to 19.2 without problem

Maybe something different when coming from 9.2.8?

I assume I can use krescue to start from zero and install the 19.2. I am currently preparing for that

yes i think ! u must check coreelec forum or other sources for details about updates !